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1 Introduction

1.1 Getting started

Welcome to BookCAT!

BookCAT is a powerful database program designed to catalog and manage a personal,
club, school, church, or business library. BookCAT will help you know what you have,
where it is (including books lent out) and the total value of your collection. Using
BookCAT you can quickly catalog your books by downloading information from the
Internet. A comprehensive set a data fields enables you to keep track of a wide range of
information.

The first time you start BookCAT, you see the "Welcome" screen. To open the sample
database (Sample.mdb) click Open Sample Database. This database contains a few
books to help you familiarize yourself with the program. Before you can start cataloging
your collection, you must create your own database .

The main BookCAT window is divided into three parts: 

1. The menu/toolbar at the top of the window.

2. The view bar to the left. 

3. The rest of the window is occupied by the active view. There are a total of 6
different views: Explorer View, Book View, Contents View, Lookup View, Loan
View, and Want List View. 

Here is the Explorer View:

10
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When you open a database, the program opens the Book View by default. To activate
another view, click the view you want to activate in the view bar, select from the View
button on the toolbar, or use the View menu. 

For example, to activate the Explorer View, open the View menu and choose Explorer
View (you can also press the Ctrl+1 shortcut). The Explorer is a fully featured browser
integrated into the main window that allows you to search/browse your collection.

You will probably use the Book View the most. This is the view you use when you want
to add new books. To active the Book View, choose Book View from the View menu
(or simply press the Ctrl+2 shortcut).
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All views, except the Explorer view, utilize the same layout. 

The main part of the view is occupied by the browse list, with the explorer pane below
the list.

To the left of the browse list you see the grouping list, and above this, the drop-down
list with available grouping definitions . The grouping feature is used to determine
which books that are displayed in the browse list, and makes it possible to work with a
subset of the database (for example, books written by a specific author). 

Above the browse list, you see three drop-down lists:

· The drop-down list to the left includes available list layouts . A list layout
contains information about which fields to display in the book list. You can create
as many list layouts as you want.

· The drop-down list in the middle includes available sort orders . A sort order
defines the order in which books are displayed. The data in the database remains
the same; only the way data is being displayed changes. Note: You can also
change the sort order by clicking the header of the column you want to sort on.

62
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· The drop-down list to the right includes available filters . A filter is used to
determine which books that are displayed in the browse list, and makes it
possible to work with a subset of the database (for example, books you have
purchased this year, or books that are for sale).

To add a new book and manually enter the data, choose Add from the Book menu (or
press the Ctrl+N shortcut). 

To download data from the Internet, choose Add - Download from Internet from the
Book menu (or press the Ctrl+Y shortcut). For more information, see Download
information from the Internet .

To edit a book, simply double-click the book you want to edit in the browse list. This
opens the 'Book Edit' window.

To close the data entry window, click the OK button (or choose Close Window from
the File menu). All changes are automatically saved.

If you need support , don't hesitate to contact us. If you want to order BookCAT,
please see our web site.

We hope you enjoy using BookCAT!

60
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1.2 System Requirements

To run BookCAT you need

· Windows 7/Vista/XP

· 1 GHz processor or better 

· 1 GB memory

· 30 MB available hard-disk space 

· Minimum 1024x768 screen resolution 

1.3 Add-Ons

BookCAT Importer

BookCAT Importer can import data from many applications, including Book Collector,
Book Library and Readerware. 

Report Archive Reader

This freeware program is used to read and print archived reports. Report archiving lets
you store report output so that it can be previewed and printed later, without re-
accessing the data from which the report was generated. While archiving is very useful
for maintaining historical records, it can also be used as a method of report distribution.
Feel free to give this application to friends or colleagues, who can then preview and
print your archived reports.

For more information about the add-ons available for BookCAT, visit http://www.fnprg.
com/bookcat/addons.html.

1.4 How to order BookCAT

For information on how to buy your own BookCAT license, visit our website.

Upgrade policy

Upgrades with the same major version number (for example from v10.00 to v10.05)
are free. In addition, all new versions released within 6 months of your registration are
free. There will be an upgrade fee for a new version with a new major version number
(for example an upgrade from v10.30 to v11.00).

http://www.fnprg.com/bookcat/addons.html
http://www.fnprg.com/bookcat/addons.html
http://www.fnprg.com/bookcat/buy.html
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1.5 Support

Technical support is available by e-mail, or you can use the online support forum.
Although we answer all questions, we give priority to registered users. Before you
contact us, check out the help file first!

When reporting problems, the more information you can provide the better our
response can be. If possible, include the following:

· What version of BookCAT are you running? You can determine this by choosing
About from the BookCAT Help menu. Include the entire "version line"; for
example "10.05.01".

· What version of Microsoft Windows are you running? For example, Windows 7 or
Windows XP.

· Is the problem reproducible? If so, how?

· If you see a dialog box with an error message when the problem occurs, please
include the complete error message.

E-mail

support@fnprg.com

Support Forum

http://www.fnprg.com/forum

 

1.6 Contacting FNProgramvare

All bug reports and suggestions are welcome.

E-mail

info@fnprg.com

World Wide Web

http://www.fnprg.com

Postal address

FNProgramvare

Pb 721 Krapfoss

N-1509 Moss

Norway

mailto:support@fnprg.com
mailto:info@fnprg.com
http://www.fnprg.com/forum
mailto:info@fnprg.com
http://www.fnprg.com
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2 Using BookCAT

2.1 Working with databases

2.1.1 About databases

The information about your book collection is stored in a database. A database is a file
on your hard disk, with the extension .MDB, that contains all the information you have
entered into the database.

For more information, see the BookCAT database .

2.1.2 Create a new database

1. Choose New Database from the File menu.

You see the 'New Database' window.

2. Select the database template you want to base the new database on.

In general, we recommend you select the Standard template.

3. Click OK.

You see the 'New Database – Specify File Name' window.

4. Select the drive and directory where you want to create the database.

In general, we recommend that you create the database in the Database folder.
This folder is selected by default, unless the open database is located in another
folder.

5. In the File name text box, type the name of the database.

The name should be one that easily reminds you of the information in the
database, for example My Book Collection or Book Library. The file extension
identifying the database, .MDB, is added automatically.

6. Click Save.

BookCAT creates the database and opens it. The file name of the database is displayed
on the title bar of the main BookCAT window. You can now begin adding information.

If you want to organize your collection using only one database, then you do not have
to think about databases again. BookCAT will always open this database when you start
the application. If, however, you choose to organize your collection in a way that
requires several databases, follow the steps above to create as many as you need. To
switch from one database to another, see Open a database .

89

11
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2.1.3 Open a databases

To open a database, choose Open Database from the File menu and select the
database file you want to open.

Note that BookCAT will automatically open the last database you had open the next
time you start the program.

The last five databases you have had open are displayed at the bottom of the File
menu (right above Exit). Simply select the database you want to open.

2.1.4 Password protect a database

BookCAT allows you to password protect your database to prevent unwanted users from
opening the database. In addition to setting up a master password, which will give full
access to the database, you can also set up a guest password. A guest will not be able
to add, edit, or delete any information in the database.

1. Choose Change Password from the File menu.

You see the 'Change Password' window.

2. If the database is already password protected, specify the current master
password in the Master password/Current password field.

3. Type the new master password in the Master password/New password field.

A password can contain any combination of letters, numerals, spaces, and
symbols, and it can be up to 25 characters long. As you type the password, the
program displays an asterisk (*) for each character you type.

4. Retype the new password in the Master password/Verify new password field.

5. If you would like to set up a guest password, fill in the Guest password/
Current password field (if a guest password has already been set up), then type
the new guest password in the Guest password/New password field, and
retype the password in the Guest password/Verify new password field.

Note: You can check the Log in as guest without password box to add the
ability for guests to log in without having to specify a password.

6. Click OK.

The next time you open the database you must specify a password.

When you create a password, write it down and keep it in a secure place. If you lose
the password, you cannot open or gain access to the password protected database.

If you would like to remove the password protection, click the Remove button and
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enter the current master password.

2.1.5 Compact a database

As you change data in a database, the database file can become fragmented and use
more disk space than necessary. Periodically, you can compact your database to
defragment the database file. The compacted database is usually smaller.

To compact the database, choose Compact Database from the File menu.

2.1.6 Transfer data between databases

BookCAT lets you work with as many databases as you like. This means that you can
split your collection into different databases and organize them to meet your needs. You
can later merge existing databases.

You use the Transfer command to transfer information between databases. In addition
to books, you can also transfer lookup tables, field definitions, form layouts, and views
setup between databases.

Choose Transfer from the File menu to open the Transfer window. Click the Help
button if you need help about the various options in this window.

2.1.7 Backup database and restore backup

We recommended that you backup your database(s) on a regular basis, for example
once a week. You should especially do a backup after adding many new books. The
backup can be used if some unusual event occurs which causes your database to
become corrupt and non-recoverable.

The built-in backup feature will automatically backup your database to a standard zip
file.

You can use the auto-backup feature to automatically backup the database when you
close the database/exit the program. You activate the auto-backup feature in the
Options window (Tools / Options / Backup).

Backup database

To backup a database, choose Backup Database from the File menu, and select the
folder you want to save the backup file.

Restore backup

To restore a backup, choose Restore Backup from the File menu, navigate to the
folder the backup file is located, select the backup file, then specify the folder you want
to restore the backup to.
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Since the backup file is a standard zip file, you can also open the backup file with
WinZip (or a similar program), and unzip the database file to the desired folder.

2.1.8 Repair corrupted database

If you get an error message when you try to open a database, use the Repair Database
function to try to repair the database. The BookCAT database can become corrupted if
the program is terminated while it is attempting to write to the database. This can
happen when there is a power-failure or a computer hardware problem.

To repair a database, choose Repair Database from the Tools menu, then select the
database file you want to repair.

2.1.9 Importing and exporting data

2.1.9.1 Overview

BookCAT lets you export data to various formats, including Excel files, HTML files, text
files, XML files, HomeBase, and to the notes section on an iPod.

You can import data from both Excel files and text files.

For more import options, download BookCAT Importer from our web site. With this
program you can import data from other database programs, including Book Collector,
Book Library and Readerware. Let us know if you are using another database
application and you would like to import your data into BookCAT.

The user interface is the same in all import and export windows. The list to the left
displays the saved import/export definitions. You can create as many definitions as you
like. Simply click on the definition you want to open.

Create a new definition

To create a new definition, click the Add button  above the list. You see the 'Add
New' window. For more information about the various options in this window, click the 
Help button.

Clone definition

Click the Clone button  to clone (create a copy of) the currently open definition.
Specify a new name, then click OK.

http://www.fnprg.com/bookcat/addons.html
mailto:info@fnprg.com


BookCAT Help14

© 2012 FNProgramvare

Delete definition

Click the Delete button  to delete the active definition. Confirm by clicking Yes.

Set options

Click the Options button  to set various options:

· AutoSave - Determines whether changes are automatically saved or not. 

· Change Folder - This allows you to set the folder where the definitions files are
stored. 

Rename definition

Click the Rename button  to rename the active definition. Specify the new name
and click OK.

Save or cancel changes

To save any changes you have made, simply click the Save button . Note that this
is not necessary if AutoSave is enabled. 

To cancel any changes, click the Cancel button .

2.1.9.2 Export to Excel

To open the 'Export to Excel' window, choose Export / Excel from the File menu.

This window has two tabs (three if you export book data): General and Fields (or
General, Book Fields and Contents Fields when exporting book data). Click the Help
button for more information about the options on these tabs.

Click the Export button to start the export process.

2.1.9.3 Export to HomeBase

To open the 'Export to HomeBase' window, choose Export / HomeBase from the File
menu.

This window has only one tab. Click the Help button for more information about the
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options.

Click the Export button to start the export process.

2.1.9.4 Export to HTML

You can export data to a set of HTML pages you can upload to any web site. To open
the 'Export to HTML' window, choose Export / HTML from the File menu, or click the

Export to HTML button  on the toolbar.

When you create a new export definition you see the 'Add New' window. Here you must
specify whether you want to create a 'Standard' or 'Code based' setup. Select 'Code
based' if you want to manually create and edit the xsl templates.

If you select 'Standard', you have five tabs available in the export window (General,
Index, List, Detail Page and Notes). If you select 'Code based', you only have two
(General and Notes).

Click the Help button for more information about the options on these tabs.

To start generating the HTML pages, click the Export button. Make sure you have
specified the correct output folder first.

Check the Test mode box to activate "test mode". This means that the program will
only export the first three records. This is useful if you want to check the layout of the
output without having to export all records.

Check this Preview in browser when finished box if you want the program to
automatically launch your web browser with the index page loaded after the export
process is completed.

2.1.9.5 Export to iPod notes

To open the 'Export to iPod Notes' window, choose Export / iPod Notes from the File
menu.

This function will let you export a list of your books to the notes section on your iPod.
You can now always check which books you already own when you shop. To access your
database on the iPod, select the Notes menu entry, and then BookCAT.

The books are automatically grouped by author. You can export a simple list, or include
a detail page for each book. You can easily set up which fields you want to export, and
a filter to limit which books to export.

This window has two tabs: General and Detail Page. Click the Help button for more
information about the options on these tabs.
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Click the Export button to start the export process.

2.1.9.6 Export to text file

To open the 'Export to Text File' window, choose Export / Text File from the File
menu.

This window has two tabs (three if you export book data): General and Fields (or
General, Book Fields and Contents Fields when exporting book data). Click the Help
button for more information about the options on these tabs.

Click the Export button to start the export process.

2.1.9.7 Export to XML

To open the 'Export to XML' window, choose Export / XML from the File menu.

This window has two tabs: General and Fields. Click the Help button for more
information about the options on these tabs.

Click the Export button to start the export process.

2.1.9.8 Import from Excel

To open the 'Import from Excel' window, choose Import / Excel from the File menu.

The first you need to do is to create a new import definition. In the 'Add New' window
you must give the new import definition a name, and select the table you want to
import data into. You can import data to any table, for example Book, Contents, Want
List, or any of the lookup tables (Person, Publisher, Genre, etc.).

This window has two tabs (three if you import book data): General and Fields (or
General,  Book Fields and Contents Fields when importing book data). Click the Help
button for more information about the options on these tabs.

Click the Import button to start the import process.

2.1.9.9 Import from text file

To open the 'Import from Text File' window, choose Import / Text File from the File
menu.

The first you need to do is to create a new import definition. In the 'Add New' window
you must give the new import definition a name, and select the table you want to
import data into. You can import data to any table, for example Book, Contents, Want
List, or any of the lookup tables (Person, Publisher, Genre, etc.).

This window has two tabs (three if you import book data): General and Fields (or
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General, Book Fields and Contents Fields when importing book data). Click the Help
button for more information about the options on these tabs.

Click the Import button to start the import process.

2.1.10 Customizing the database

2.1.10.1 Overview

BookCAT allows you to customize your database to suit your needs. Not only can you
rename data fields and hide the fields you don't want to use, but you can also change
the layout of all data entry windows. Perhaps you want to make the Genre field wider,
or move one of the custom fields to the General tab? Change fonts or colors? Add an
image to spice up the look? No problem. You modify the layout of a data entry window
in the Form Designer. 

There are two ways to bring up the Form Designer; either from the 'Database Setup'
window, or from the actual data entry window. You can also change field properties
(field name, default value, etc.) from both the 'Database Setup' window and the Form
Designer.

To open the 'Database Setup' window, choose Database Setup from the Tools menu.
For more information, see The Database Setup window .

To open the Form Designer, either select the appropriate table in the 'Database Setup'
window and click the Form Designer button, or choose Form Designer from the File
menu in the data entry window. For more information on how to use the Form Designer,
see The Form Designer .

2.1.10.2 The Database Setup window

To open the 'Database Setup' window, choose Database Setup from the Tools menu.
The main part of this window is occupied by a tab control with two tabs: Tables and
Fields.

The list on the Tables tab gives you an overview of all tables in the database.

17

20



BookCAT Help18

© 2012 FNProgramvare

This list has three columns. The first column displays the default table name, the
second column the active table name, and the last column indicates whether the table
is in use or not. 

You can change the sort order by clicking the heading of one of the columns. The
properties list to the right displays the properties of the selected table. Context
sensitive help is available for each property.

To edit the fields in the selected table, click the Fields tab. 
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The list on the Fields tab gives you an overview of all fields in the selected table. This
list has four columns. The first column displays the default field name, the second
column the active field name, the third column the field group, and the last column
indicates whether the field is in use or not. 

You can change the sort order by clicking the heading of one of the columns. The
properties list to the right displays the properties of the selected field. Context sensitive
help is available for each property.

When you want to modify a field, it is important that you select the correct table before
you activate the Fields tab. For example, to modify the Chapters field in the Contents
table, first select the Contents table on the Tables tab, then click the Fields tab to
display the fields in the Contents table.

You can save the database setup as a database template. This template can then be
used when creating a new database. This is useful if you want to share the database
setup with others. 
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2.1.10.3 The Form Designer window

2.1.10.3.1  Overview

You use the Form Designer to modify the layout of data entry windows. You can add or
remove data fields, move fields around, change the size of field controls, modify fonts
or colors, etc. 

Please note that you cannot create any *new* data fields.

To activate the Form Designer, either select the appropriate table in the 'Database
Setup' window and click the Form Designer button, or choose Form Designer from
the File menu in the data entry window.

Before you start modifying a form, we recommend you backup the original layout to a
file by choosing Save to File from the File menu. If you later decide you want to revert
to the original layout, you can load the form layout file with the Load from File
command.

There are 7 object types you can add to a form:

 Text
The text object is usually linked to a data field, but you can also use it,
for example, to add a heading to the form. 

When you add a data field, the program will by default also add a
corresponding text label. The text label is then linked to a data field by
the Field property, and the actual field name is displayed (and
automatically updated if you rename the field). You can override this by
filling in the Text property if you want to display a different text.

 Field
This is the form object you will use the most. When you add a data
field, the user interface control for the selected field is added to the
form. The control type depends on the actual type of field. For a
standard text field (for example Title or Custom 01) this is a text box,
for a lookup field (for example Publisher or Custom 05) this is a drop-
down list, and for a checkbox field (for example Custom 11) this is a
checkbox.

 Tab
Control

The tab control is a set of pages used to create a multipage control. 

For more information on how to use the tab control, see How to use the
tab control .

 Group
Box

Use the group box to group fields. All fields placed inside a group box is
part of this box, and will move when you move the group box. If you
delete the group box, all fields within are also deleted. You can give the
group box a title by using the Title property. The title is displayed along
the top edge of the group box.

22
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 Button
The button object allows you to add a button to the data entry form.
The button will execute a specific action when you click it (for example
save the changes and close the window, cancel the changes, or go to
the next record). The action is determined by the button's Type
property.

 Line
The Line object will add a vertical or horizontal line. The orientation of
the line is determined by the Orientation property.

 Image
Add an image object if you want to add an image to spice up the look of
the form. When you add an image object, you first see the 'Select
Image File' window. Here you select image file. When you click Open,
the image is added to the form. Note that the image is saved with the
form layout.

2.1.10.3.2  Add a data field

You can add a field directly on the form itself, in a group box, or on a page in a tab
control. 

1. Click the Field button  on the toolbar.

2. Click where you want to add the field.

You see the 'Insert Field' window.

3. Select the field you want to add to the form.

4. If you want the program to automatically add a corresponding text label that will
display the name of the field, select either Label/Left or Label/Top.

If you do not want to add a text label, select Label/No label.

Note: A checkbox field does not have a corresponding text label.

5. Click OK.

BookCAT adds the field control where you clicked.

6. If you need to move or resize the field, see Move a form object  or Resize a
form object .

7. If you want to edit the field properties, see Modify form or object properties .

23
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2.1.10.3.3  How to use the tab control

The tab control is a set of pages used to create a multipage control. You select a tab
(page) by clicking one of the tabs that appear at the top of the control. 

The use of a tab control is especially useful if you are working with many data fields
that can be grouped into two or more categories. You will probably only add one tab
control to a form (although you can have several tab controls on the same form). You
can add as many tabs (pages) as you like to a tab control.

To add a tab control to the form, click the Tab Control button  on the toolbar, then
click where you want to add the tab control.

To resize the tab control, first click to select it, then drag the control's surrounding
sizing handles to increase or decrease the size.

To add a tab, right-click the tab control and choose Add Tab from the popup menu. 

To remove a tab, activate the tab you want to remove, then right-click and choose 
Remove Tab from the popup menu.

You can change the ordering of the various tabs by using the Move Tab Left and Move
Tab Right functions available on the popup menu.

To rename the tabs, right-click and choose Properties, then specify the tab titles under
the Tab titles heading.

If you leave a tab title empty, the program will automatically fill in the name of the
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first field on the tab when you open the data entry window. 

 

2.1.10.3.4  Select a form object

To do certain things with an object (change the font, move it, resize it, etc.), you first
have to select it. Select means to point to the object with the mouse and then to click
the left mouse button.

To select a single object

Click on the object.

Sizing handles appear around the object to indicate that it is selected.

Selecting multiple objects

Hold down the Shift key and click on the objects you want to select.

Handles appear on each selected object. You can then move or delete the objects as a
group. You can also change the font or text formatting for all selected objects in one
operation.

2.1.10.3.5  Move a form object

1. Select the object(s)  you want to move.

2. Click on the object with the mouse, and drag it to the new position.

If multiple objects are selected, click on one of the objects and drag.

You can move the selected object(s) one pixel at a time by holding down Ctrl while you
use the arrow keys.

You cannot drag an object from one tab to another tab on a tab control. You must copy
the object to the clipboard, activate the other tab, and then paste the object onto this
tab. For more information, see Move a form object to another tab .

2.1.10.3.6  Resize a form object

1. Select the object  you want to size.

2. Drag the field's surrounding sizing handles to increase or decrease the size of the
object.
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You can resize the object one pixel at a time by holding down Shift while you use the
arrow keys.

The height of text boxes and drop-down lists is always based on the actual font size
and cannot be changed.

2.1.10.3.7  Modify form or object properties

To modify either the form properties, or the properties of a form object, right-click the
form background or the form object, and choose Properties from the popup menu.

2.1.10.3.8  Move a form object to another tab

You cannot drag an object from one tab to another tab on a tab control. You must copy
the object to the clipboard, activate the other tab, and then paste the object onto this
tab.

1. Select the object(s)  you want to move to another tab.

2. Choose Cut from the Edit menu.

BookCAT copies the object to the clipboard, and removes the object from the tab
it was located on.

3. Activate the tab you want to add the object to.

4. Right-click where you want to paste the object(s) on the clipboard, and choose 
Paste from the popup menu.
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2.1.10.3.9  Delete a form object

1. Select the object  you want to delete.

2. Choose Delete from the Edit menu (or press the Ctrl+Del shortcut).

2.1.10.3.10  How to set the tab order

The tab order is the order in which controls are activated when you press the Tab key to
move from control to control in the data entry window. The control with the Tab order
value of 0 is the control that has the focus when the form first appears. 

Initially, the tab order is always the order in which the controls were added to the form.
The first control added to the form has a Tab order value of 0, the second is 1, the third
is 2, and so on.

Fields placed on a tab page, or within a group box, have their own tab order.

If you want to use the Tab key to move from field to field, it is important that the tab
order is correct for the cursor to move in a logical order.

There are three ways to update the tab order:

· Right-click a form control and choose Properties from the popup menu, then
manually update the Tab Order property.

· Update the tab order in the 'Tab Order' window.

To activate this window, either choose Edit Tab Order from the File menu (to
update the tab order of all controls on the form), or right-click a tab page and
choose Edit Tab Order from the popup menu (to edit the tab order of only the
controls on this tab page).

The main part of this window is occupied by two lists. You select 'container' control
from the list to the left. A container control is a special control that can contain
other controls, and is either the form itself, a tab page of a tab control, or a group
box. The tab numbering is separate for each container control.

The list to the right displays the controls in the selected container control. The
order of the controls corresponds to the current tab order. To automatically update
the tab order of these controls, click the Automatic button.
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· Let the program automatically update the tab order of all form objects. For more
information, see The Auto Update Tab Order function .

2.1.10.3.11  The Auto Update Tab Order function

Choose Auto Update Tab Order from the File menu. Confirm by clicking Yes.

BookCAT automatically updates the tab order of all objects on the form.

Sometimes the program may be unable to correctly set the tab order of all fields (this
depends on the actual layout of the fields; left and top positions as well as width and
height). You then have to manually 'fine tune' the tab order in the 'Tab Order' window.

2.1.10.3.12  The Auto Update Groups function

Each data field has a Group property which is used in lists where you choose a field (for
example when creating a report or a sort order) to group the fields in the list.

By default, the group corresponds to the tab the field is located on in the data entry
window. If you move a field from one tab to another, we recommend you update the
Group property of the field. 

You can do this by right-clicking the field and choosing Properties from the popup menu
to manually modify the Group property, or you can use the Auto Update Groups
function:

26
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Choose Auto Update Groups from the File menu. Confirm by clicking Yes.

2.1.10.3.13  The Auto Update Use Property function

If you add a field to the form, or remove a field, you should also update the Use
property of the field. This property indicates whether the field is 'in use', or not. 

Only fields that are considered to be in use are shown in lists where you select a field
(for example when creating a report, a sort order, or when searching). Use the Auto
Update Use Property function to automatically update the Use property of all fields in
the table.

Choose Auto Update Use Property from the File menu. Confirm by clicking Yes.

2.2 Data entry

2.2.1 Types of information

BookCAT stores several types of information:

·  Books. You can enter information such as such as author, title, publish
date, publisher, ISBN, cover image, etc. "Book" is a general term that can mean a
book, newspaper, magazine, and so forth.

You work with books in the Book View.

·  Contents. You can enter contents data (sections) such as author, title, page
from, page to, keywords, etc. "Contents" is a general term for any work (poems,
short stories, individual essays, etc) contained within the book (a book can
contain multiple sections)

You work with contents data in the Contents View.

Note: To add new contents data, bring up the 'Book Edit' window, and add
contents data via the contents list.

·  Lookup tables. Lookup tables are lists that contain information linked to
data fields, for example the Person, Publisher or Genre lists. When you modify an
entry in a lookup table, for example to fix a typing error, the change will be
reflected in all data fields that are linked to this lookup table.

You work with lookup tables in the Lookup View.

Select the lookup table you want to edit from the View button on the toolbar.
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·  Loan data. This includes both books that currently are on loan, and the
complete loan history.

Open the Loan View to look at the loan history. 

To get an overview of books current out on loan you can also use the Book View
(select the On Loan filter).

·  Want list. The want list allows you to keep track of books you have on your
want list. You can enter information such as author, title, publisher, ISBN, order
date, and price.

You edit the want list from the Want List View.

2.2.2 Edit books

You add, edit and delete books from the Book View.
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Add new books

To manually add a new book, click the Add button  on the toolbar. This will open
the 'Book Edit' window.

To download data from the Internet, click the Add - Download from Internet button

 on the toolbar. For more information, see Download information from the Internet
.

Edit books

Select the book you want to edit in the book list, and either click the Edit button 
on the toolbar, or simply double-click the book. This will open the 'Book Edit' window in
edit mode.

Delete books

Select the book you want to delete in the book list, then click the Delete button 
on the toolbar. You can also press the Ctrl+D shortcut. Confirm that you really want to
delete the book by clicking Yes.

If you have selected  more than one book, all selected books will be deleted.

2.2.3 Edit contents

You add, edit and delete sections (contents data) in a specific book from the 'Book Edit'
window. You can also edit contents data from the Contents View.

Add new sections

Open the 'Book Edit' window, and click the Add Section button  below the contents
list.
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You see the 'Contents Edit' window, and can start entering information.

To add the next section in the book, click the Add button  on the toolbar in the
'Contents Edit' window (or simply press the Ctrl+N shortcut). When you have added all
the contents data in the book, click OK to close the 'Contents Edit' window.

Edit sections

To edit a section from the 'Book Edit' window, simply double-click the section you want
to edit in the contents list. 

You can also edit contents data from the Contents View.

Delete sections

Locate the book that contains the section you want to delete, open the 'Book Edit'
window, select the section in the contents list, then click the Delete Section button

 below the contents list. Confirm by clicking Yes.

To delete multiple sections, first select (click while you hold down the Ctrl key) all the
sections you want to delete, then click the Delete Section button.

Rearrange the order of the sections

To rearrange the section order, simply use drag-and-drop in the contents list in the
'Book Edit' window. Select the sections you want to move, and then drag it to the new
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position. 

You can also rearrange sections from the 'Contents Edit' window. Choose Rearrange
from the Contents menu to open the Rearrange window. 

2.2.4 Contents templates

A contents template allows you to specify information that is relevant to all sections (or
most of the sections) when you register a new book (this is useful if, for example, the
book contains multiple sections written by the same author). The information you
specify is automatically used when you add new sections. You can also save a template
to a file and reuse it later.

You can also use a contents template to register information after all sections are added
to the book. For example, if you only specified titles when you originally registered the
book, you can assign a contents template to the sections in the book at a later time.
This allows you to register information for all sections in the book in one operation.

Modifying the active template

1. Choose Template from the Contents menu (you can do this from both the 'Book
Edit' and the 'Contents Edit' window).

You see the 'Contents Template' window.

2. Modify the template information as necessary.

3. Click OK.

The updated template is activated, and is automatically used when you add new
sections to the current book.

Assigning a contents template to sections

1. Choose Template from the Contents menu (you can do this from both the 'Book
Edit' and the 'Contents Edit' window).

2. Modify the template information as necessary.

3. Click the Assign button  on the toolbar.

You see the 'Assign Template to Sections' window.

4. Select the sections you want to assign the template to.

Note: You can click and drag up or down to select multiple sections.

5. Click the OK button to assign the template to the selected sections.
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2.2.5 Edit lookup information

You can edit lookup tables from both the Lookup View, and the 'Edit Lookup Table'
window. To open this window, right-click a data field linked to a lookup table (for
example Publisher), and choose Edit Lookup Table from the popup menu.
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If you prefer to use the Lookup View, select the lookup table you want to edit from the
View button on the toolbar.



BookCAT Help34

© 2012 FNProgramvare

In the Lookup View you can browse lookup items the same way you browse books in
the Book View.

From both the Lookup View and the 'Edit Lookup Table' window you can add, edit and
delete lookup items.

2.2.6 Split a lookup item

After you have downloaded data from the Internet, you may end up with a lookup item
you need to split up into multiple items. This is easy, just follow this procedure:

1. Bring up the data entry window for the lookup item you want to edit.

2. Click the Split button  on the toolbar. 

You see the 'Split Lookup Item' window.

3. Specify the separator you want to use when splitting up the text, then click the 
Split button.

4. BookCAT adds the new lookup values to the list below. 
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You can now edit the new lookup values before you save the changes to the database.

5. Click the Update button to save the changes.

BookCAT adds the new lookup items to the lookup table, then updates all data
fields linked to this lookup table.

Please note that single item lookup fields (for example Publisher) will only contain the
value on the first row in the list after you have used the Split function. 

2.2.7 Author pseudonyms

With the new pseudonym feature in version 10 you can easily find all books written by
a specific author, no matter which pseudonym is used. For this to work you need to add
the author's "real name" in the Person lookup table, and enter the pseudonym(s) in the
Pseudonym field in the Edit Person window, like this:
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(You can add and edit authors from the Lookup View, or by right-clicking the Author
field and choosing Edit Table. For more information on how to work with lookup tables,
click here .)

In the Edit Person window, you can go to either a "pseudonym record", or the "real
name record", by selecting from the Pseudonym/Real Name button on the toolbar:

32
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When you are adding book data, select the pseudonym in the Author field:

The real author name is displayed after the pseudonym in the explorer, the browse list
and in reports:

Books written under a pseudonym are automatically found when you search the Author
Pseudonym field with the author's real name, or use the grouping feature:

All pseudonyms are listed when you explore the author credits. Here are two examples:
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2.2.8 Edit the want list

You use the want list to keep track of books you have on your want list. You can track
basic information like author, title, publisher, ISBN, order date, and price. You can also
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add your own notes.

To add a book on your want list to your collection, choose Add to Collection from the
Want List menu. BookCAT will automatically search for the book details online, and add
a new entry in the Book View. In addition, any data you have entered in the Want List
View (for example order date or price), are automatically transferred to the book entry.
Then want list entry is then deleted.

2.2.9 Edit images

BookCAT allows you to store up to 9 images with each book and person (author, etc.).
You can enter notes for each image.

You can either store images in the database, or link to external image files. Linking to
external image files will keep the size of the database down, and give better
performance. You can change this setting from the Options window
(Tools=>Options=>Multimedia), or by right-clicking the image field in the data entry
window and selecting from the popup menu ("Store Images in Database" or "Link to
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Image Files"). To "extract" images stored in the database and save them as external
files, click 'Extract images' in the 'Database Maintenance' window. To load external
images and store them in the database, click 'Load external images' in the 'Database
Maintenance' window.

Select image

To select one of the other 9 images, simply click the corresponding button:

Add a new image

To add a new image, click the Insert Image/Link to Image File button . Select
image file, and click Open. 

You can paste an image from the clipboard by clicking the Paste button below the
image field.

You can drag an image from your web browser and drop it on the image field.

Scan image

If you have a TWAIN compatible scanner, you can use the Acquire Image from Scanner
function to scan the image directly into the image field. 

To scan the image, click the Acquire button . This passes control to your scanner's
Twain software. Follow the instructions you see on the screen. 

If you have selected to store images externally, you see the 'Save Image' window.
Specify a filename, then click the Save button.

Rearrange images

You can easily move an image from one of the image slots to another. Click on the
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image, and while you hold down the mouse button, drag the image to the button
corresponding to the image slot you want to move the image to.

Remove an image

Click the Remove Image button .

Confirm by clicking Yes. If you have linked to an external image file, select whether
you want to only remove the link to the image file, or also delete the file.

The popup menu

Right-click the image field to open a popup menu with various options. From this menu
you can resize the image, open the folder containing an external image, paste an image
from the clipboard, or copy the image to the clipboard.
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Auto-Organize image files

You can automatically organize external image files into a folder structure and filename
format of your choice. To use this feature, choose Auto-Organize Image Files from the
Tools menu.

If you have selected "Link to Image Files", these settings are also used when you
download images from the Internet, paste an image into an image field, drag an image
to an image field, use the "Extract Images" feature, etc.

Locate Missing Image Files

If BookCAT is unable to locate external image files because you have moved the files
you link to from your database, you can use the Locate Missing Image Files function
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available on the Tools menu. This will scan the specified drive/folder (select "My
Computer" to scan all drives) and attempt to locate the missing image files.

2.2.10 The Set Field Value function

To set the value of a data field, regardless of the current field value, for multiple
records, use the Set Field Value function (this works differently from the Search &
Replace function where you replace a specific value with another value).

1. Right click the browse list and choose Set Field Value from the popup menu. 

You see the 'Set Field Value - Select Field' window.

Note: If you right-click the heading of a column, the program will bypass the
'Select Field' window and let you update the field you right-clicked.

2. Select the field you want to update, then click OK.

3. You see the 'Set Field Value: [Field Name]' window.

Select whether you want to update all records (books, sections, persons, etc.), 
the marked records , or the selected records  in the browse list.

4. When updating a multivalue field, for example Genre or Keyword, you can check
the Remove existing data box if you want to remove all existing data in this
field before the new field value is saved.

5. Specify the new field value, click OK, then confirm by clicking Yes.

When you update a multivalue field (for example Genre or Keywords), the new field
value is added to the existing lookup items if you do not check the 'Remove existing
data' box.

2.2.11 Download information from the Internet

BookCAT allows you to download information like book title, author, publisher, publish
year, keywords etc. from the Internet. 

54 55
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Adding new books

1. Make sure the Book View is active, then choose Add - Download from

Internet  from the Book menu.

You see the 'Download from Internet (Add New)' window.

The first time you open the 'Download from Internet' window BookCAT
automatically opens the 'Options - Download from Internet' window. Here you
select the sites you want to query. You can later open this window by clicking the 
Options button on the toolbar.

2. Type the ISBN/LCCN number into the ISBN/LCCN text box, then click the Add
button (or simply press Enter).

If you have a barcode scanner, you can scan the barcode on the book cover into
this field. BookCAT will automatically convert the barcode to an ISBN number.

Note: Most barcode scanners will automatically add a Carriage Return after the
barcode number when you scan the barcode. If your scanner does not do this you
will have to press Enter after you have scanned the barcode.
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Note: To load a file of ISBN/LCCN numbers or bar codes from a text file into the
list, choose Load List from the File menu, then select the file you want to import
from.

3. Repeat step 2 for all books you want to retrieve data from the Internet.

4. Choose Download from the File menu, or click the Download button

 on the toolbar.

Wait while BookCAT downloads the book data.

5. Before you transfer the downloaded book data to the database, we recommend
that you check the downloaded data. To do this, simply choose Edit from the
Book menu to open the 'Edit' window.

6. Click the Next button to edit the next book in the list. When finished, click OK to
close the window.

7. To transfer the books the database, choose Transfer from the Book menu, or

click the Transfer button  on the toolbar.
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BookCAT will transfer all books with a status of either "Found" or "Manual Entry".

If some information isn't downloaded correctly, click the Report Problem button to
report any problems to support. BookCAT will prepare an email with the selected sites
and a list of the isbn it tried to download. 

Updating existing books

To update existing books with information downloaded from the Internet, follow this
procedure:

1. From the Book View, select the book you want to update, then open the 'Book
Edit' window.

2. Choose Update - Download from Internet  from the Book menu.

The program downloads the available data.

You see the 'Download from Internet (Update)' window.

Here you can edit the data.

3. Fields that already contains information are by default not updated. To update all
fields (overwrite existing information), check the 'Overwrite existing data' box.

4. Click OK.

2.2.12 Loan management

2.2.12.1 Overview

BookCAT lets you to track books out on loan; you can easily loan out a book, set a due
date and search for all books out on loan and overdue books.

You can use a bar code scanner when checking books in and out of the library. BookCAT
will handle any bar code scanner that enters data via a keyboard interface. These are
often referred to as "wedge" readers as they wedge themselves in between the
keyboard and your computer. 

If you have a bar code scanner, use the 'Check Titles In/Out' window to quickly check
books in and out of the library. If you do not have a bar code scanner, you can
manually check books in and out one at a time, or you can use the 'Check Titles In/Out'
window if you manually look up books and borrowers.

To get an overview of books current out on loan you can select the On Loan filter in the
Book View. From the Loan View you can browse the complete loan history. On the
Report menu you find various loan reports that you can print out. 

In addition, BookCAT also allows you to place reservations  for books on loan, and to49
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automatically clear reservations .

You can also send e-mail notifications to borrowers. This could be a reminder that a
book should be returned soon or is overdue, or a notification that a reserved book is
ready for collection. For more information, see To send e-mail notifications .

2.2.12.2 Check books out one at a time

1. Locate the book you want to check out.

2. Choose Check Out from the Loan menu.

You see the 'Check Out' window.

3. Select the name of the borrower from the Borrower drop-down list.

If the borrower is not registered, right-click the Borrower field and choose Add
from the popup menu. Complete the information requested in the 'Borrower Edit'
window, then click the OK button.

4. In the Date Borrowed field, specify the date the book was borrowed. By default,
BookCAT fills in today's date.

5. In the Date Due field, specify the date the book is due to be returned.

6. Click OK.

Even though BookCAT lets you change the name of the borrower in the 'Check Out'
window, always check the book in before you check it out again. This is important if
you want the loan history to be correct.

2.2.12.3 Check books in one at a time

1. Locate the book you want to check in.

2. Choose Check In from the Loan menu.

You see the 'Check In' window.

3. In the Date Returned field, specify the date the book was returned. By default,
BookCAT fills in today's date.

4. Click OK.

Even though BookCAT lets you change the name of the borrower in the 'Check Out'
window, always check the book in before you check it out again. This is important if
you want the loan history to be correct.

49

50



BookCAT Help48

© 2012 FNProgramvare

2.2.12.4 Check books out using the 'Check Titles In/Out' window

1. Choose Check Titles Out from the Loan menu.

You see the 'Check Titles In/Out' window.

2. Make sure the Date Borrowed and Date Due fields are correctly filled in.

3. If you have a bar code scanner (and the borrower's barcode number is registered
in the Borrower lookup table), scan the bar code on the borrowers library card
into the Borrower field. BookCAT will automatically lookup the borrower name.

If you don't have a bar code scanner, click the Search button  to manually
search for the borrower.

4. If you have a bar code scanner, scan the bar code on the book into the Title field.
BookCAT will automatically look up the book in the database and add it to the list
below.

If you don't have a bar code scanner, click the Search button  to manually
search for the book you want to check out.

5. Repeat step 4 for all books you want to check out to the selected borrower.

6. Click the Update button.

7. If you would like to print out a receipt, click the Print Receipt button.

Note: If you would like to automatically print the receipt when you click the
Update button, click the drop-down button to the right and select Automatically
Print Receipt from the popup menu.

Note: If you would like to edit the layout of the receipt, click the drop-down
button to the right and choose Open in Report Designer from the popup menu.

2.2.12.5 Check books in using the 'Check Titles In/Out' window

1. Choose Check Titles In from the Loan menu.

You see the 'Check Titles In/Out' window.

2. Make sure the Date Returned field is correctly filled in.
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3. If you have a bar code scanner, scan the bar code on the book into the Title field.
BookCAT will automatically look up the book in the database and add it to the list
below.

If you don't have a bar code scanner, click the Search button  to manually
search for the book you want to check in.

4. Repeat step 3 for all books you want to check in.

5. Click the Update button.

6. If you would like to print out a receipt, click the Print Receipt button.

Note: If you would like to automatically print the receipt when you click the
Update button, click the drop-down button to the right and select Automatically
Print Receipt from the popup menu.

Note: If you would like to edit the layout of the receipt, click the drop-down
button to the right and choose Open in Report Designer from the popup menu.

2.2.12.6 Reserve a book

1. Locate the book you want to reserve in.

2. Choose Reserve from the Loan menu.

You see the 'Reserve' window.

3. Select the name of the borrower from the Borrower drop-down list.

If the borrower is not registered, right-click the Borrower field and choose Add
from the popup menu. Complete the information requested in the 'Borrower Edit'
window, then click OK.

4. In the Reserved Date field, specify the reservation date. By default, BookCAT
fills in today's date.

5. Click OK.

2.2.12.7 Clear reservations

1. Choose Clear Reservations from the Loan menu.
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You see the 'Clear Reservations' window.

2. Specify the age of the reservations you want to clear.

For example, if you specify 7 days, the program will clear all reservations placed
more than one week ago.

3. Click OK.

You can manually clear a reservation if you select the book in the Book View, and then
choose Clear Reservation from the Loan menu.

2.2.12.8 Send e-mail notifications

1. Choose Send E-mail Notifications from the Loan menu.

You see the 'Send E-mail Notification' window.

2. Make sure the From / Name and From / Address fields are filled in.

3. If you haven't already done so, click the Server button and specify mail server,
username, and password.

4. To send notifications to borrowers that have books that are overdue, click the 
Overdue tab.

To send notifications to borrowers that have books that will become overdue
soon, click the Reminder tab.

To send notifications to borrowers that have reserved books ready for collection,
click the Reservation tab.

5. Specify the relevant time period.

6. Make sure the Subject, Body 1,and Body 2 fields are filled in.

Body 1 is the text that is added before the list of books. Body 2 is the text that is
added after the list.

You can use the following codes in the text (the code is replaced with the field
value when the e-mail message is generated):

%
DA
TE
%

The current date.

% The borrower's full name.
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NA
ME
%

%
FIR
ST
%

The borrower's first name.

%LAST
%

The borrower's last name.

7. Click the Send button to send the e-mail notifications.

After the e-mails have been sent BookCAT will create a log file with details about
all the processed borrowers with information about sent e-mails, borrowers with
no e-mail address, and any errors. Click the 'Log file' button to open this log file.

2.2.12.9 Extend loan period

You can extend the loan period by a specified number of days.

1. In either the Book View or the Loan View, select  the records you want to
update.

2. From the Loan menu, choose Extend Loan Period.

3. Enter the number of days you want to extend the loan period by.

4. Confirm by clicking Yes.

BookCAT updates the 'Date Due' field.

2.3 Viewing information

2.3.1 Working with views

The main BookCAT window is divided into three parts: 

1. The menu/toolbar at the top of the window.

2. The view bar to the left. 

3. The rest of the window is occupied by the active view. There are a total of 6
different views: Explorer View, Book View, Contents View, Lookup View, Loan
View, and Want List View. 
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You can select the view you want to open in the view bar. The currently open view is
highlighted in bold:

You can also select view from the toolbar:
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or the View menu (notice the shortcut keys):

In addition to this, you can also select view, including the lookup table you want to edit in the
Lookup View, from the View button on the toolbar:

If the View button/View title section is hidden, choose Select View from the View
menu (or press the Ctrl+W shortcut) to select lookup table.
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When you select one of the standard views, the program activates the view with the
same settings loaded as the last time you used the view. This means that the same list
layout , sort order , filter , and grouping definition  are automatically activated.

In addition, you can create your own custom views, enabling you to easily access
relevant information in your database (books, contents data, authors, genres, etc.). A
custom view can be linked to a specific list layout, sort order, filter and grouping
definition. Choose Views Setup from the View menu to set up your own custom views.

2.3.2 Marking records and showing the marked records

BookCAT allows you to mark records in any table. Marking and unmarking records can
be useful if you want to select different records based on specific criteria. You can view,
edit, search among, or print only the records that have been marked.

The checkmark button  on the toolbar indicates whether the current record is
marked or not. If the button is "in" (pressed), the record is marked. If it is
"out" (released), the record is not marked. You can also simply press Ctrl + M to mark
or unmark the current record.

You can also mark / unmark records by clicking the checkbox in the first column in the
browse list.

To mark all records

1. Choose Mark / Mark All from the menu (for example the Book menu if the Book
View is active). 

Note: If this command is disabled (not available), it means that all records
already are marked.

To unmark all records

1. Choose Mark / Unmark All from menu (for example the Book menu if the Book
View is active). 

Note: If this command is disabled (not available), it means that no records are
marked.

At the bottom of the main window, notice the 4 numbers in the first section of the

56 58 60 62
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statusbar:

It shows the active record's position in the list (4), number of records displayed in the
list (19), number of records that are marked (5), and the total number of records in the
table (37).

Notice, for example, how the statusbar is updated when you use the mark commands.

By default, BookCAT displays all records in the active table. If you want to view only the
records that are marked, select the Marked Records option on the List menu. This
option toggles between the two modes. If only marked records were shown, all records
are now shown again. If all records were shown, only the marked records are now
shown.

2.3.3 Select multiple records in browse list

In order to set the field value of several records in one operation, delete multiple
records, etc, you must first select these records in the browse list:

· To select consecutive records, click the first record, press and hold down Shift,
and then click the last record.

· To select nonconsecutive records, press and hold down Ctrl, and then click each
record you want to select.

· To select all records, choose Select All from the List menu (or press the Ctrl+A
shortcut).

Here we have selected the first 10 genres in the Genre table (Lookup View):
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· To clear the selection, click in the upper left corner of the list:

Don't confuse selecting records with marking records .

2.3.4 List layouts

Each view (except the Explorer View) contains a browse list. In a standard list layout,
each row in the grid corresponds to a record in the table (books in the Book View,
sections (contents data) in the Contents View, genres in the Genre Lookup View, and so
on). Each field is displayed in a separate column. The active row is highlighted so that it
easy to see which record that is selected. In a card list, there is one cell per record.

When you create a new database, BookCAT automatically adds various standard list
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layouts to the database. A list layout contains information about which fields to display,
the font to use and so on. You can easily modify the default layouts, or create your own
layouts.

You select list layout from the drop-down to the left above the browse list.

You can also manage the list layouts in the active view by choosing List Layouts from
the View menu. Here you can both add, edit and delete list layouts.

Create a new list layout

To create a new list layout, right-click the list layout drop-down list and choose Add
List Layout from the popup menu. 

This will open the 'Add List Layout' window. Here you can select the fields you want to
display in the list, select font, etc.

When you create a new list layout in the Book View or the Person Lookup View, you
first see the 'Add List Layout - Select Type' window. Here you must select whether you
want to create a standard list layout, or a card list.

Edit a list layout

To edit a list layout, first select the list layout you want to edit, then right-click the list
layout drop-down list and choose Edit List Layout from the popup menu. This will open
the 'Edit List Layout' window.

Add a new column

To add a new column, right-click the browse list and choose List Layout / Add
Column from the popup menu. This will open the 'Select Field window. Select the field
you want to display in the list, then click OK. Then you see the 'Column Properties'
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window. Here you can modify the properties of the column, such a text alignment, color
and column width. Click OK to add the new column to the list.

You can move the column to a new position in the list by using drag-and-drop (hold
down the Alt key while you drag).

Edit a column

To edit the properties of a column, right-click the column you want to edit and choose 
List Layout / Edit Column from the popup menu.

Rearrange the columns

To rearrange the order of the columns:

1. Press down the Alt key.

2. While you hold down the Alt key, click on the heading of the column you want to
move, and drag it to it's new position.

3. Release both the mouse button and the Alt key.

Remove a column

To remove a column, right-click the column you want to remove and choose List
Layout / Remove Column from the popup menu. Confirm by clicking Yes.

Delete a list layout

To delete a list layout, first choose List Layouts from the View menu, then select the
list layout you want to delete and click Delete. Confirm by clicking Yes. 

2.3.5 Sort orders

You use a sort order to define the order in which records are displayed. The data in the
database remains the same; only the way data is being displayed changes. BookCAT
lets you sort on up to five fields.

There are two ways to change the sort order:

· Select a sort order from the sort order drop-down list above the browse list.

· Click the heading of the column you want to sort on to create a temporary sort
order.

A field can be sorted in either ascending order (letters are sorted from A to Z and
numbers from 0 to 9) or descending order (letters are sorted from Z to A and numbers
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from 9 to 0).

You select sort order from the drop-down in the middle above the browse list.

You can also manage the sort orders in the active view by choosing Sort Orders from
the View menu. Here you can both add, edit and delete sort orders.

Create a new sort order

To create a new sort order, right-click the sort order drop-down list and choose Add
Sort Order from the popup menu. 

This will open the 'Add Sort Order' window.

Edit a sort order

To edit a sort order, first select the sort order you want to edit, then right-click the sort
order drop-down list and choose Edit Sort Order from the popup menu. This will open
the 'Edit Sort Order' window.

Delete a sort order

To delete a sort order, first choose Sort Orders from the View menu, then select the
sort order you want to delete and click Delete. Confirm by clicking Yes. 

Create a temporary sort order

Click on the heading of the column you want to sort on. Letters are by default sorted
from A to Z and numbers from 0 to 9. Hold down Shift while you click to create a
descending sort order (letters are sorted from Z to A and numbers from 9 to 0). Hold
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down Ctrl while you click to sort on multiple columns. You can sort on up to five
columns.

A sort indicator is used to display the sort order status of a column. If the arrow points
upwards the column is sorted in ascending order. If the arrow points downwards the
column is sorted in descending order.

A temporary sort order is deleted when you select one of the saved sort orders. 

Save a temporary sort order

1. Right-click the browse list and choose Save Sort Order as from the popup menu.

You see the 'Save Sort Order As' window.

2. Give the sort order a title, and click OK.

The sort order is now available from the sort order drop-down list.

2.3.6 Filters

A filter is used to determine which records that are displayed in the browse list, and
makes it possible to work with a subset of the database (for example, books purchased
this year, or books that are for sale). 

You select filter from the drop-down to the right above the browse list.

You can also manage the filters in the active view by choosing Filters from the View
menu. Here you can both add, edit and delete filters.

Create a new filter

To create a new filter, right-click the filter drop-down list and choose Add Filter from
the popup menu. 
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This will open the 'Add Filter' window.

Edit a filter

To edit a filter, first select the filter you want to edit, then right-click the filter drop-
down list and choose Edit Filter from the popup menu. This will open the 'Edit Filter'
window.

Delete a filter

To delete a filter, first choose Filters from the View menu, then select the filter you
want to delete and click Delete. Confirm by clicking Yes. 

Use the Quick Filter feature

The Quick Filter feature allows you to filter on a field value displayed in the browse list.

To create a quick filter, right-click the field value you want to filter on in the browse list,
and choose Quick Filter from the popup menu.

To clear the filter, right-click the browse list and choose Clear Filter from the popup
menu.

A quick filter is deleted when you select a saved filter. If you want to save the quick
filter, right-click the browse list and choose Save Quick Filter as from the popup
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menu.

2.3.7 Grouping

The grouping feature is used to determine which records that are displayed, and makes
it possible to work with a subset of the database (for example, books written by a
specific author).

Using the grouping feature is similar to using a filter, except that it is easier to change
the value used in the filtering process. For example, if you group by author, you can
simply select another author to display the books by this author (if you used a filter you
would have to modify the filter to get the same result).

The first item in the list represents the open database. Select this item to display all
records in the table.

You select grouping definition from the drop-down above the grouping list.

You can also manage the grouping definitions in the active view by choosing Grouping
Definitions from the View menu. Here you can both add, edit and delete grouping
definitions.

Create a new grouping definition

To create a new grouping definition, right-click the grouping definition drop-down list
and choose Add Grouping Definition from the popup menu. 
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This will open the 'Add Grouping Definition' window.

Edit a grouping definition

To edit a grouping definition, first select the grouping definition you want to edit, then
right-click the grouping definition drop-down list and choose Edit Grouping Definition
from the popup menu. This will open the 'Edit Grouping Definition' window.

Delete a grouping definition

To delete a grouping definition, first choose Grouping Definitions from the View
menu, then select the grouping definition you want to delete and click Delete. Confirm
by clicking Yes.

2.3.8 The explorer

BookCAT Explorer is a great way to browse your collection. The data is presented in the
same way as when you use your web browser. You can click hyperlinks to look at
related information. For example, you can click an author's name to see more
information about that author, including a list of books he has written.  

You can use the explorer in three ways:

· From the Explorer View.

· Use the "preview pane" below the browse list. This preview pane is available in all
views.

· Use the separate Explorer window. Simply press F11 to bring up the window. The
displayed information depends on the type of data selected.

The preview pane is useful when you want to look at the basic information. The
Explorer View or the Explorer window is better when you want all the details.

To change the default colors and other settings in the explorer, right-click the explorer
page and choose Options from the popup menu.
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Customizing the layout with XSL templates

You can completely customize the layout of the explorer with the help of XSL templates.
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XSL is a language for defining style sheets. It also includes a transformation language
for XML documents: XSLT. Originally intended for complex styling operations, like
generating indexes and tables of contents, it is now used as a general purpose XML
processing language.

Styling requires two things: a source XML document containing the information the
style sheet will display, and the style sheet itself (the XSL template) which describes
how the information will look.

This section is not intended to be a complete XSL/XML tutorial, but will give you some
basic information on the different types of xsl templates that BookCAT uses. For more
information about XSL and XML, see http://www.w3schools.com/xsl and http://www.
w3schools.com/xml.

A BookCAT XSL template is a text file containing HTML instructions defining the layout
of the page, and XSLT commands that extract and process data from the XML data file. 

The standard BookCAT XSL templates are located in the \Explorer Templates folder.

To edit an existing template, right-click the explorer page and choose Edit XSL
Template from the popup menu. We recommend that you backup the original template
file before you edit the template.

BookCAT uses three different template types. The type of template is determined by the
data type instruction at the beginning of the xsl template file. Possible values are:

<?data type="index"?>

<?data type="record"?>

<?data type="list"?>

index This type of template is only used by the Explorer view, and in the Explorer
window when you click the Home button. 

For an example of this template type, see Index.xsl.

record This type of template is used to create a document with data about one
specific record. Use the data table instruction to specify which table the data
should be taken from, for example <?data table="book"?>.

For an example of this template type, see Book.xsl.

list This type of template is used to create a document with a list of multiple
records. Use the data table instruction to specify which table the data should
be taken from, for example <?data table="book"?>.

http://www.w3schools.com/xsl
http://www.w3schools.com/xml
http://www.w3schools.com/xml
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For an example of this template type, see BookList.xsl.

The explorer pane is by default displayed below the browse list. To display the explorer
pane to the right of the browse list, add the <?data previewpanepos="right"?>
instruction to the xsl template file. For an example, see the BookBrowse_Right.xsl
template.

2.4 Searching and querying

2.4.1 How to search

You can effectively search the database for information that you require. Search in all
fields with any combination of fields and operators.

There are several different ways to search and query data:

1. Quick Search . This is the easiest and quickest way to search. The quick search
function will search the records displayed in the browse list. By default, it will only
search the text fields you actually see in the list. You can also search all fields in
the table (however, this is slower).

2. Simple search . Lets you define a search criteria based on one or two fields. You
specify field, operator and the value you want to search for. The search criteria
can be saved to a file for later use.

3. Advanced search . Lets you define a search criteria that can contain an (almost)
unlimited number of fields. You can group the fields in different ways using
parenthesis and the logical operators AND/OR. The search criteria can be saved to
a file for later use.

4. Summary search . Specify the field you want to search in from the drop-down
list. All unique values, and the number of occurrences of each value, are then
displayed in a list. Select the value you want to search for and click OK.

5. Global Search . Lets you search in all fields.

If you want to replace a field value with another value, use the search and replace
command.

In addition, BookCAT has various "special searches " that give you features not
available in the other searches.

Before you execute a search, you must specify the following options:

Search marked

Select the 'Search marked' option if you only want to search the marked records.
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Show books

When searching for contents data, select the 'Show books' option if you want the
books the sections are located in as the search result.

Searches are case insensitive (that is, BookCAT does not distinguish between upper
and lower case).

You can add saved search criteria to the Search menu. If you save the search file in
the \Search folder, the search will automatically appear on the Search menu. You can
manually manage the searches on the menu by choosing Edit Menu from the Search
menu.

2.4.2 Quick search

The quick search will search the records displayed in the browse list. By default, it will
only search the text fields (standard text, lookup and memos) you actually see in the
list. You can also search all text fields in the table (however, this is slower). 

You select this from the drop down menu linked to the Quick Search button on the
toolbar:

Type the text you want to search for in the text box, and click the Search button

 (or simply press Enter). 

The search result is immediately shown in the browse list. To clear the search, click the 

Clear button .

By default, the program will search for fields containing the text you specify. If you
would like to search for fields that begins with this text, add * after the text (for
example Summer*).

2.4.3 Simple search

The simple search lets you define a search criteria based on one or two fields. You
specify field, operator and the value you want to search for. The search criteria can be
saved to a file for later use.
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To use the simple search, choose Simple from the Search menu.

2.4.4 Advanced search

The advanced search lets you define a search criteria that can contain an (almost)
unlimited number of fields. You can group the fields in different ways using parenthesis
and the logical operators AND/OR. The search criteria can be saved to a file for later
use.

To use the advanced search, choose Advanced from the Search menu.



Using BookCAT 69

© 2012 FNProgramvare

2.4.5 Summary search

Choose Summary from the Search menu to open the 'Summary Search' window.

Specify the field you want to search in from the drop-down list. All unique values, and
the number of occurrences of each value, are then displayed in a list. Select the value
you want to search for and click OK.
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You can click the heading of one of the two columns to change the sort order.

2.4.6 Global search

With the global search you search in all book and contents fields.

Choose Global from the Search menu to open the 'Global Search' window.
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2.4.7 The special searches

The special searches give you features not available in the other searches. You can, for
example, search for invalid ISBN numbers.
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2.4.8 Search and replace

Use the search and replace function to replace a field value with another value.

Choose Replace from the Search menu to open the 'Search and Replace' window.

Click the Help button if you need help about the various options in this window.

To set the value of a field regardless of the current field value, use the Set Field Value
 function.

2.5 Working with reports

2.5.1 About reports

When you want to print out data, you can bring up the Report Designer to create a new
report, select a pre-defined report from the Report menu, or use the Print List command
to print the contents of the browse list.

Printing the browse list

To print the browse list, choose Print from the File menu. This will open the 'Print List'
window.

43



Using BookCAT 73

© 2012 FNProgramvare

Click the Help button if you need more help about the various options in this window.

Report Designer

BookCAT includes a report designer that lets you create almost any type of report. You
have full control over data fields, groups, sort order, columns, fonts, colors, paper size,
margins and print orientation. You can add your own reports to the Report menu so that
you can easily print them later.

Choose Report Designer from the Report menu to open the Report Designer.

Predefined reports

On the Report menu you also find all the pre-defined reports that ships with BookCAT.
Simply select the report you want to print. This will open the 'Print Report' window.
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2.5.2 The report designer

You use the Report Designer to create new reports, and to modify existing reports. 

Reports are made up of bands. The way data appears in a report is determined by the
kind of band a report object (data field, image, line, shape, etc.) is in.

The Report Designer makes extensive use of popup menus. To display a popup menu,
right-click a band or report object. You can also specify the text formatting (font, font
size, color, and text alignment) from the Format toolbar. The text formatting affects all
selected objects.

To open the Report Designer, choose Report Designer from the Report menu.
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2.5.3 Report files

Before you can create a new report, or open a saved report, you must open the 'Report
Designer' window.

Create a new report

Choose New from the File menu. You see the 'New Report' window.

Select the type of report you want to create, then click OK.

Save a report

To save the report you are working on, choose Save from the File menu. When you
save the report for the first time, you see the 'Save Report' window. Here you select the
folder you want to save the report in, and specify a filename.

If you have previously saved the report, BookCAT will just save all changes to the same
report file. Choose Save As from the File menu to save the report with a different
name.

Open a saved report

Choose Open from the File menu, locate the folder the report you want to open is
located in, select the report file and click Open.
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2.5.4 Report options

Page setup

To change the page setup, choose Page Setup from the File menu.

To specify default margins that are automatically used in all new reports, choose 
Default Margins from the File menu.

Grouping

Grouping a report means breaking the data into meaningful groups before it appears in
your report. Data grouping is used to create easy-to-read blocks of data. You can create
up to five groups in a report.

For each group, there are two corresponding bands: the Group Header and the Group
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Footer. These bands will only print when the value of the group field changes. The
Group Header is printed above the Detail band, while the Group Footer is printed below
the Detail band.

To set up the grouping, choose Grouping from the Report menu.

Sort order

To change the sort order, choose Sort Order from the Report menu. You can sort on
up to five data fields.
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Filter

Use a filter to specify what information you want to print. To set up a filter, choose 
Filter from the Report menu.

This will open either the 'Simple Filter' or the 'Advanced Filter' window based on the
'Search/filter type' setting in the 'Options' window.

What information to include

You can include all records in your report, or you can restrict your report to specific
records; either the marked records, the current record (record selected in the main
window), or let the filter specify what records to include.

You set this up by selecting from the Report / Include menu.
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2.5.5 Report bands

Reports are made up of bands. The way data appears in a report is determined by the
kind of band a report object (data field, image, line, shape, etc.) is in. 

For example, objects in the Page Header band will appear at the top of each page.
Objects in the Page Footer band will appear at the bottom of each page. And the objects
in the Detail band will repeat down the page until no more page space is available, at
which point a new page will be started (the Detail band prints once for each record in
the table the report is based on).

The number of available bands depends on the report type. For example, the Sub-detail
band is only available in a book report, and the Column Header band is only available if
the report has more than one column (you set up the number of columns in the 'Page
Setup' window).

Band types

Title

The Title band prints on the first page of the report, above the Page Header band.

Page Header

The Page Header band prints at the top of each page, except the first page where it
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is printed after the Title band.

Column Header

The Column Header band prints at the top of each column. This band is only
available in reports with more than one column.

Group Header

The Group Header band prints before the Detail band each time the group value
changes. There is one Group Header band for each group (a report can have up the
five groups).

Detail

The Detail band prints once for each record in the table the report is based on. For
example, in a book report the Detail band prints once for each book that is printed.

Sub-Detail

The Sub-Detail band prints once for each section (contents data) in the book. The
sections are always printed in the order they appear in the book. This band is only
available in book reports.

Detail 2

The Detail 2 band prints after the Sub-detail band, and is useful if you want to add
some space after the contents data before the next book, or if you want to print
some book fields after the contents data. This band is only available in book reports.

Group Footer

The Group Footer band prints after the Detail/Sub-detail/Detail 2 bands each time
the group value changes. There is one Group Footer band for each group (a report
can have up the five groups).

Column Footer

The Column Footer band prints at the bottom of each column. This band is only
available in reports with more than one column.

Page Footer

The Page Footer band prints at the bottom of each page.

Summary

The Summary band prints on the last page of the report, above the Page Footer
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band.

Edit band properties

To modify the properties of a band (for example height or fill color), right-click the band
and choose Properties from the popup menu.

Resize band

To resize a band click the band's title bar (the part of the band that displays the band
name) and drag while you hold down the mouse button. Release the mouse button
when the band has the desired height.

You can also edit the band properties, and manually set the Height property.

Hide and show band

To hide or show a band, simply open the Report menu and select the band you want
hide or show. If it is currently hidden, it will be shown. If it is currently shown, it will be
hidden.

2.5.6 Report objects

BookCAT has nine different objects you can use in reports. This enables you to put all
types of data in your reports; text, images, lines, shapes, etc

 Text

The Text object simply prints the text you specify, and is typically used for report titles,
page headings, field names, etc. 

When you add a Text object to the report, you see the 'Text' window. Here you enter
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the text (you can later modify the text by editing the object properties).

Use the code %date% to have BookCAT insert the current date when the report is
printed.

Use the code %filter:#% to have BookCAT insert the filter value when the report is
printed. For example, %filter:1% will print the first, and %filter:2% the second filter
value. 

 DBField

The DBField object is used to print text from a data field in the database, and is the
report object you will use the most. 

When you add a DBField object to the report, you see the 'Select Field' window. Here
you select data field.

 DBCalc

The DBCalc object is used to perform common report calculations and print the
resulting value. The calculation is performed based on the value of the specified data
field. 

When you add a DBCalc object to the report, you see the 'Select Field' window. Here
you select the data field the calculation should be based on. 

 DBMulti-field

A DBMulti-field combines text from two or more report objects. This allows you to print
data from several data fields without unnecessary space between the fields. Each data
field can be formatted independently. 

When you add a DBMulti-field object to the report, you see the '[DBMulti-field name]'
window. Here you select the report objects (Text, DBField, or DBCalc) you want to
include.

 DBXsl

The DBXsl object will let you use an xsl template to format the output of the report
object. You can include any field from the table the report is based on, and use different
fonts and colors, tables, etc. The xsl template is used to create a html document, which
is then included in the report. To use this report object you need to know how to create
and edit XSL templates! 
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 System 

The System object is used to print common report information, such as date or page
number. The data that is printed is determined by the Type property.

 Shape

The Shape object is used to print graphical shapes. The shape that is printed is
determined by the Type property.

 Line

The Line object is used to print a vertical or horizontal line. The orientation of the line is
determined by the Orientation property. Use the Style property to control whether a
single or double line is printed.

 Image

Use the Image object to print a graphical image. 

When you add an Image object to the report, you see the 'Select Image File' window.
Here you select image file.
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Insert object

Select the report object you want to insert from either the Insert menu, or the toolbar,
then click in the band you want to add the report object to.

Select object

To do certain things with an object (change the font, move it, resize it, etc.), you first
have to select it. Select means to point to the object with the mouse and then to click
the left mouse button.

To select a single object

Click on the object.

Sizing handles appear around the object to indicate that it is selected.

   

Selecting multiple objects

Hold down the Alt key and click on the objects you want to select.

Handles appear on each selected object. You can then move or delete the objects as a
group. You can also change the font or text formatting for all selected objects in one
operation.

   

Move object

First select the object you want to move, then click on the object with the mouse and
drag it to the new position.

You can move the selected object(s) one pixel at a time by holding down Ctrl while you
use the arrow keys.

Resize object

First select the object you want to resize, then drag the field's surrounding sizing
handles to increase or decrease the size of the object.
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You can resize the object one pixel at a time by holding down Shift while you use the
arrow keys.

Edit object properties

To modify the object properties (for example height or fill color), right-click the object
and choose Properties from the popup menu.

Delete object

First select the object you want to delete, then choose Delete from the Edit menu (or
simply press the Ctrl+Del shortcut).

Move object to another band

You cannot drag an object from one band to another band. You must copy the object to
the clipboard and then past it onto the other band.

1. Select the object you want to move to another band.

2. Choose Cut from the Edit menu.

BookCAT copies the object to the clipboard, and removes it from the band it was
located on.

3. Right-click the band you want to paste the object into, and choose Paste from
the popup menu.
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2.5.7 Print the report

To print the report from the Report Designer window, click either the Print , Print

Preview  or Print to File  button on the toolbar.

If you just want to check the report layout, hold down Ctrl while you choose the print
command. This will tell BookCAT will only print the first page of the report.

You can also print reports from the main window by choosing a saved report from the
Report menu.

2.5.8 The report menu

BookCAT comes with many pre-defined reports. These reports are available from the
Report menu.



Using BookCAT 87

© 2012 FNProgramvare

As long as you save the reports you create in the \Reports folder, BookCAT will
automatically show the reports on the Report menu. 

If not, you can manually edit the Report menu by choosing Edit Menu from the Report
menu. Here you can add new reports, remove reports, or update the action that is
performed when a report is chosen from the menu (print the report, preview it, send it
to a file, show the 'Print Report' window, or bring up the Report Designer).
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3 The BookCAT Database

3.1 Overview

The information about your book collection is stored in a database. A database is a file
on your hard disk, with the extension .MDB, that contains all the information you have
entered into the database.

A database consists of several tables. Each table contains related information. For
example, there is one table with information about each book, one with information
about each person, one with information about each publisher, and so on. Each table
contains a various number of fields. For example, the Person table has a field for the
name of the person, one field for the date of birth, one field for comments, and so on.

BookCAT lets you change the name of all tables and all fields. You can specify a default
value for most fields. You can hide the fields you don't want to use. They will then
disappear from all windows, menus, lists etc. You only use the fields you want.

BookCAT lets you work with an unlimited number of databases. This means that you
can split your collection into different catalogs and organize it to meet your needs. You
can later merge existing databases.

BookCAT uses a relational database model. This means that you register most
information only once. For example, you only need to type the name of an author the
first time you add a book by this author. Later, you simply choose the name from a list.
BookCAT then automatically creates a link between the book and the author. When you
modify an entry in a lookup table, for example, to fix a typing error, the change will be
reflected in all fields that are linked to the lookup table.

The use of lookup tables to store information has two significant advantages: it saves
time and conserves valuable disk space on your computer. It also makes it easier to
search for exactly the information you are looking for, or create a group based report.
And finally, it allows you to store useful information about each entry in a lookup table.
For example, you can store a person's e-mail address or a publisher's home page URL.

3.2 Book table

3.2.1 Standard fields

The Book table contains information about all books in the database. Information from
lookup tables (for example Publisher) is not stored in the Book table, BookCAT only
saves a link to the relevant item in the lookup table. This means that any changes you
make to a lookup item, for example fixing a typing error, is reflected in all books where
the item is used.

Acquired From (Text 50 - lookup )

Where you bought the book, who you got it from, etc.

105
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Appraiser (Text 50 - lookup )

The name of the appraiser (this could be a person, a catalog, etc.).

Author (Text 50 - lookup )

The name of the author(s). In the first column, type the name of the person. In the
second column, specify the role you want to link the person to (Co-Author, Editor, etc.).

Author Pseudonym (Text)

Use this field to search for all books written by a specific author, no matter which
pseudonym is used. For this to work you need to edit the "real name" in the Person
lookup table, and enter the various pseudonyms in the Pseudonym field. You find more
information here .

Author Relation (Text)

This field includes all related authors.

Awards (Text 100)

Here you can specify awards. You can also specify the year the award was given and
any additional details.

Barcode (Text 50)

The bar code number.

Binding (Text 50 - lookup )

Use this field to specify binding (Hardcover, Paperback, etc.).

Book ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Borrower (Text - lookup )

If the book is currently loaned out, this field contains the name of the borrower.

Category (Text 50 - lookup )

The category describes the type of book.

Note: By default this field is not visible in the data entry window (you can add it with
the Form Designer). You might want to use the Genre field instead.
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Change in Value (Numeric)

The difference between price and value.

Change in Value % (Numeric)

The difference between price and value in percent.

Condition (Text 50 - lookup )

Use this field to specify the condition of the book.

Copyright Date (Date)

The book's copyright date. If you don't know the day and month, just specify the year.

Country (Text 50 - lookup )

The country of origin.

Cover Price (Numeric)

The cover price. You can specify both the actual price, and the currency.

Cover 1-9 (Binary)

This field contains the actual image if the image is stored in the database.

Cover 1-9 - Compressed (Yes/No)

Specifies whether the image is compressed or not (only applies to BMP images).

Cover 1-9 - External (Yes/No)

Specifies whether the image is stored externally (only the file path to the image file is
stored in the database), or not.

Cover 1-9 - File Name (Text 255)

If you have linked to an external image, this field contains the file name.

Cover 1-9 - Notes (Memo)

This memo field is for your own notes about the image.

Cover 1-9 - Thumbnail (Binary)
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This is a thumbnail of the image. The thumbnail is automatically created when you add
a new image. 

Cover 1-9 - Type (Numeric)

The type of image: 0 - bmp, 1 - gif, 2 - jpeg, 3 - png, or 99 - other.

Credits (Text 50 - lookup )

Use this field for any additional credits. In the first column, type the name of the
person. In the second column, specify the role you want to link the person to (Cover
Design, Illustrator, etc.).

Current Value (Numeric)

The book's current value.

Date Acquired (Date)

The date you acquired the book. If you don't remember the day and month, just specify
the year. Click on the calendar icon to display a pop-up calendar where you can select
the date. 

Date Borrowed (Date)

If the book is currently loaned out, this field contains the date it was borrowed.

Date Due (Date)

If the book is currently loaned out, this field contains the date it is due to be returned.

Dewey (Text 25)

The dewey decimal number.

Dimensions - Depth (Numeric)

The depth of the book

Dimensions - Height (Numeric)

The height of the book.

Dimensions - Width (Numeric)

The width of the book.
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Dustjacket Condition (Text 50 - lookup )

Use this field to specify the dustjacket condition.

Edition (Text 50 - lookup )

The book's edition.

File Links (Text)

Here you can add links to external files.

Full Title 1 (Text)

This field combines Title, Series and Release No into one field: Series (Release No):
Title.

Full Title 2 (Text)

This field combines Title, Series and Release No into one field: Title (Series Release
No).

Genre (Text 50 - lookup )

You can assign the book to as many genres as you like (for example "Biography",
"Education", "History" or "Science Fiction"). One of the genres can be the "primary"
genre (shown in bold). 

When entering data, the first genre you select is automatically set as the primary
genre. To set another genre as the primary genre, right-click and choose "Primary
Genre" from the popup menu, or simply press Ctrl+Space.

Insurance (Text 50 - lookup )

Use this field to link the book to an insurance policy.

ISBN (Text 25)

The ISBN number (International Standard Book Number).

Keywords (Text 150 - lookup )

This field is for listing keywords that describe the book.

Language (Text 50 - lookup )

The language.
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Last Modified (Date)

The date/time the record was last modified. This field is automatically updated by
BookCAT when you edit data.

Last Read (Date)

The date you last read the book.

LCCN (Text 25)

The LCCN number (Library of Congress Catalog Number).

Location (Text 50 - lookup )

Use this field to specify the location of the book.

Main Author (Text - lookup)

This field includes authors that are not assigned to any author role.

Marked (Yes/No)

This field indicates whether the book is marked or not.

New Book (Yes/No)

This field indicates whether the book is new, and is based on the Date Acquired field. By
default, if it's less than 60 days since you acquired the book, this field returns Yes. If
not, it returns No.

Note: You can change the number of days used in this calculation by choosing
Tools=>Options=>Data Entry, and specifying the new value in the 'New book period'
text box. Default value is 60 days.

Nominations (Text 100 - lookup )

Here you can specify award nominations. You can also specify the year the nomination
was given and any additional details. 

Notes (Memo)

This memo field is for your own notes.

Number of Sections (Numeric)

This field contains the number of sections in the book, and is automatically maintained
by BookCAT.
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On Loan (Yes/No)

This field indicates whether the book is currently on loan.

Original Country (Text 50 - lookup )

If the book is translated, use this field to specify the original country of origin.

Original Language (Text 50 - lookup )

If the book is translated, use this field to specify the original language.

Original Publish Date (Date)

If the book is translated, use this field to specify the original publish date.

Original Publisher (Text 150 - lookup )

If the book is translated, use this field to specify the original publisher.

Original Release No (Numeric)

If the book is translated, use this field to specify the release number in the series.

Original Series (Text 50 - lookup )

If the book is translated, use this field to specify the name of the original series.

Original Subtitle (Text 255)

If the book is translated, use this field to specify the original subtitle.

Original Title (Text 150)

If the book is translated, use this field to specify the original title.

Overdue (Yes/No)

If the book is loaned out, this field indicates whether it is overdue or not.

Owner (Text 50 - lookup )

The owner of the book.

Pages (Numeric)

The total number of pages.
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Personal Rating (Text with image - lookup )

Use this field to specify your own personal rating. The default setup will let you select a
star rating between 0 and 5 stars.

Primary Genre (Text 50 - lookup )

The primary genre. For more information, see the Genre field.

Printed by (Text 50 - lookup )

The name of the company that has printed the book.

Printing (Text 50 - lookup )

The printing (1st printing, 2rd printing, etc.).

Publication Place (Text 50 - lookup )

The publication place (name of the city, and state or province, and country, if needed to
identify the city) where the book was published or released. 

Publish Date (Date)

The publish date. If you don't know the day and month, just specify the year.

Publisher (Text 150 - lookup )

The name of the publisher.

Purchase Price (Numeric)

What you paid for the book.

Reference No (Text 25)

Use this field if you have your own system for identifying books in your collection.

BookCAT will automatically generate the reference number. To configure this feature,
choose Tools=>Options=>Reference No and make your selections.

Registered (Date)

This field contains the date the book was added to the database. Today’s date is used
automatically, but you can change it if you want. Click on the calendar icon to display a
pop-up calendar where you can select the date. 
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Release No (Numeric)

If the book is part of a series, use this field to specify the release number.

Reviews (Memo)

This memo field is for reviews.

Selling Price (Numeric)

Use this field to specify the selling price.

Series (Text 50 - lookup )

If the book is part of a series, specify the name of the series in this field.

Status (Text 50 - lookup )

The status of the book, for example "Own" or "For sale".

Sub-Category (Text 50 - lookup )

In addition to the Category field, you can use the Sub-category to describe the type of
book.

Note: By default this field is not visible in the data entry window (you can add it with
the Form Designer). You might want to use the Genre field instead.

Subtitle (Text 255)

If the book has a subtitle, enter it here.

Synopsis (Memo)

This memo field is for the synopsis.

Title (Text 150)

The title of the book. 

Note: When you tab out of the Title field (or save the book), BookCAT will automatically
fill in the Title Sort field if it is empty.

Title Sort (Text 152)

This is the value that is used when sorting on the book title. When you tab out of the
Title field (or save the changes), BookCAT will automatically fill in the Title Sort field if
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it is empty. If the name begins with “A” or “The”, BookCAT will automatically update the
Title Sort field to reflect this. For example, if you type “The Hobbit” in the Title field,
BookCAT will add “Hobbit, The” to the Title Sort field. This means that the book is
sorted under "H" and not "T".

Type (Text 50 - lookup )

Use this field to specify the type of book, for example "Fiction" or "Non-fiction".

Web Links (Text)

Here you can add links to web sites. 

3.2.2 Custom fields

To rename a custom field, open the data entry window, right-click the data field and
choose Rename Field from the popup menu. You can also rename fields from the
'Database Setup' window (Tools=>Database Setup). 

The Book table contains the following custom fields:

Text 

Custom 01, Custom 02, Custom 03, Custom 04

Lookup 

Custom 05, Custom 06, Custom 07, Custom 08

Multivalue lookup 

Custom 19

Date 

Custom 09, Custom 20

Numeric 

Custom 10, Custom 21

Checkbox 

Custom 11, Custom 12, Custom 13, Custom 14, Custom 15, Custom 16, Custom 17,
Custom 18, Custom 22, Custom 23, Custom 24, Custom 25
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3.3 Contents table

3.3.1 Standard fields

The Contents table contains information about all sections (chapters, short stories,
individual essays, etc., contained within books). 

Author (Text 50 - lookup )

The name of the author(s). In the first column, type the name of the person. In the
second column, specify the role you want to link the person to (Co-Author, Editor, etc.).

Author Pseudonym (Text)

Use this field to search for all works written by a specific author, no matter which
pseudonym is used. For this to work you need to edit the "real name" in the Person
lookup table, and enter the various pseudonyms in the Pseudonym field. You find more
information here .

Author Relation (Text - lookup)

This field includes all related authors.

Book ID (Numeric)

The book's ID number. You cannot edit this field.

Chapters (Text)

You can use this field to register the chapters of the book. The list has three columns:
Title, Page From and Page To.

Contents ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Copyright Date (Date)

The copyright date. If you don't know the day and month, just specify the year.

Country (Text 50 - lookup )

The country of origin.

Credits (Text 50 - lookup )

Use this field for any additional credits. In the first column, type the name of the
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person. In the second column, specify the role you want to link the person to (Cover
Design, Illustrator, etc.).

File Links (Text)

Here you can add links to files.

Full Title 1 (Text)

This field combines Title, Series and Release No into one field: Series (Release No):
Title.

Full Title 2 (Text)

This field combines Title, Series and Release No into one field: Title (Series Release
No).

Index (Numeric)

This field contains the section's index number, and is automatically maintained by
BookCAT.

Item (Numeric)

This field contains the item the section is located in, and is automatically maintained by
BookCAT.

Keywords (Text 150 - lookup )

This field is for listing keywords that describe the book.

Language (Text 50 - lookup )

The language.

Last Modified (Date)

The date/time the record was last modified. This field is automatically updated by
BookCAT when you edit data.

Main Author (Text - lookup)

This field includes authors that are not assigned to any author role.

Marked (Yes/No)

This field indicates whether the section is marked or not.
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Notes (Memo)

This memo field is for your own notes.

Original Copyright (Date)

The original copyright date. If you don't know the day and month, just specify the year.

Original Country (Text 50 - lookup )

If the work is translated, use this field to specify the original country of origin.

Original Language (Text 50 - lookup )

If the work is translated, use this field to specify the original language.

Original Publisher (Text 50 - lookup )

If the work is translated, use this field to specify the original publisher.

Original Release No (Numeric)

If the work is translated, use this field to specify the release number in the series.

Original Series (Text 50 - lookup )

If the work is translated, use this field to specify the name of the original series.

Original Subtitle (Text 255)

If the work is translated, use this field to specify the original subtitle.

Original Title (Text 150)

If the work is translated, use this field to specify the original title.

Page From (Text 15)

The first page.

Page From-To (Text)

This field includes both Page From and Page To as one field (for example, 10-25).

Page To (Text 15)

The last page.
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Release No (Numeric)

If the work is part of a series, use this field to specify the release number.

Series (Text 50 - lookup )

If the work is part of a series, specify the name of the series in this field.

Title (Text 150)

The title.

Title Sort (Text 152)

This is the value that is used when sorting on the title. When you tab out of the Title
field (or save the changes), BookCAT will automatically fill in the Title Sort field if it is
empty. If the name begins with "A" or "The", BookCAT will automatically update the
Title Sort field to reflect this.

Type (Text 50 - lookup )

The type of work, for example "Essay", "Short Story", or "Poem".

3.3.2 Custom fields

To rename a custom field, open the data entry window, right-click the data field and
choose Rename Field from the popup menu. You can also rename fields from the
'Database Setup' window (Tools=>Database Setup). 

The Contents table contains the following custom fields:

Text 

Custom 01, Custom 02, Custom 03

Lookup 

Custom 04, Custom 05, Custom 06

Date 

Custom 07, Custom 16

Numeric 

Custom 08, Custom 09
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Checkbox 

Custom 10, Custom 11, Custom 12, Custom 13, Custom 14, Custom 15, Custom 17,
Custom 18, Custom 19, Custom 20

3.4 Loan table

The Loan History table contains information about books that are out on loan, and
books that previously have been loaned out. You can't modify this table directly, but
BookCAT updates the table when you check a book in or out.

Borrower (Text 50 - lookup )

The name of the borrower.

Date Borrowed (Date)

The date the book was borrowed.

Date Due (Date)

The date the book is due to be returned.

Date Returned (Date)

The date the book was returned. If the book is not yet returned, this field is empty.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Overdue (Yes/No)

If the book is loaned out, this field indicates whether it is overdue or not.

Returned (Yes/No)

This field indicates whether the book is returned or not.

3.5 Want List table

The Want List table allows you to keep tracks of books you intend to buy.

Author (Text 50 - lookup )

The author name(s).
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Binding (Text 50 - lookup )

The binding (Hardcover, Paperback, etc.).

ISBN (Text 25)

The ISBN number (International Standard Book Number).

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This field is for your own notes.

Order Date (Date)

The date you ordered the book.

Ordered From (Text 50 - lookup )

The store you have ordered the book from.

Price (Numeric)

The price you paid.

Priority (Numeric)

The priority; 1, 2, or 3.

Publisher (Text 50 - lookup )

The name of the publisher.

Publish Date (Date)

The publish date. If you don't know the day and month, just specify the year.

Release No (Numeric)

If the book is part of a series, use this field to specify the release number.

Series (Text 50 - lookup )

If the book is part of a series, specify the name of the series in this field.
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Title (Text 150)

The title.

Title Sort (Text 150)

The sort title  When you tab out of the Title field (or save the changes), BookCAT will
automatically fill in the Title Sort field if it is empty. 

3.6 Lookup tables

3.6.1 Acquired From table

Two fields are linked to this lookup table: Book.Acquired From and Want List.Ordered
From.

Acquired From (Text 50)

The name of the store where you bought the book, who you got it from etc.

Acquired From ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Address (Memo)

E-mail (Text 100)

Fax (Text 25)

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Phone (Text 25)

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

Web Link (Text 100)
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3.6.2 Appraiser table

One field is linked to this lookup table: Book.Appraiser.

Appraiser (Text 50)

The name of the appraiser (this could be a person, a magazine, a catalog etc.). Use the
Sort by field to specify the value that is used when sorting on this item.

Appraiser ID (Numeric)

This is an unique ID number that is assigned to each entry in the table.

Address (Memo)

This is a memo field where you can specify the appraiser’s address.

E-mail (Text 100)

Here you can specify the e-mail address.

Fax (Text 25)

Here you can specify fax number.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This field is for your own notes.

Phone (Text 25)

Here you can specify phone number.

Sort by (Text 52)

This is the value that is used when sorting on this item. 

Web Link (Text)

Here you can specify the home page URL.  
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3.6.3 Award table

Two fields are linked to this lookup table: Book.Awards and Book.Nominations.

Award (Text 100)

The name of the award.

Award ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 102)

This text value is used when sorting on a field linked to this lookup table. 

3.6.4 Binding table

Two fields are linked to this lookup table: Book.Binding and Want List.Binding.

Binding (Text 50)

The binding description, for example "Hardcover" or "Paperback".

Binding ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 102)
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This text value is used when sorting on a field linked to this lookup table. 

3.6.5 Book Type table

One field is linked to this lookup table: Book.Type.

Book Type (Text 50)

The type of book, for example "Fiction" or "Non-fiction".

Book Type ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

3.6.6 Borrower table

3.6.6.1 Standard fields

Two fields are linked to this lookup table: Book.Borrower and Loan History.Borrower.

Barcode (Text 50)

Borrower ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Address (Memo)

Category (Text 50 - lookup )

Use this field to assign the borrower to a user defined category.

E-mail (Text 100)

110
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Fax (Text 25)

Marked (Yes/No)

This field indicates whether the record is marked or not.

Name (Text 50)

The name of the brorrower.

Notes (Memo)

This memo field is for your own notes.

Phone (Text 25)

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

Web Link (Text)

3.6.6.2 Custom fields

To rename a custom field, open the data entry window, right-click the data field and
choose Rename Field from the popup menu. You can also rename fields from the
'Database Setup' window (Tools=>Database Setup). 

The Borrower table contains the following custom fields:

Text 

Custom 01, Custom 02

Lookup 

Custom 03, Custom 04

Multivalue lookup 

Custom 12

Memo

Custom 05

Date 
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Custom 06

Numeric 

Custom 11

Checkbox 

Custom 07, Custom 08, Custom 09, Custom 10

3.6.7 Borrower Category table

One field is linked to this lookup table: Borrower.Category.

Borrower Category (Text 50)

The borrower category. Use categories to assign a borrower to a user defined category. 

Borrower Category ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

3.6.8 Category table

One field is linked to this lookup table: Book.Category.

Category (Text 50)

The category description.

Category ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.
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Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table.  

3.6.9 Condition table

One field is linked to this lookup table: Book.Condition.

Condition (Text 50)

The condition.

Condition ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table.  

3.6.10 Contents Type table

One field is linked to this lookup table: Contents.Type.

Contents Type (Text 50)

The type of work, for example "Essay", "Short Story", or "Poem".

Contents Type ID (Numeric)
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This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table.  

3.6.11 Country table

Five fields are linked to this lookup table: Book.Country, Book.Original Country,
Contents.Country, Contents.Original Country and Person.Country.

Country (Text 50)

The name of the country.

Country ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table.  

3.6.12 Dustjacket Condition table

One field is linked to this lookup table: Book.Dustjacket Condition.

Dustjacket Condition (Text 50)
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The dustjacket condition.

Dustjacket Condition ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table.  

3.6.13 Edition table

One field is linked to this lookup table: Book.Edition.

Edition (Text 50)

The edition description.

Edition ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table.  

3.6.14 File Link Type table

You can assign a type to each link in the File Links field.
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File Link Type (Text 50)

The type description.

File Link Type ID (Numeric)

This is an unique ID number that is assigned to each entry in the table.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This field is for your own notes.

3.6.15 Genre table

One field is linked to this lookup table: Book.Genre.

Genre (Text 50)

The genre, for example "Biography", "Education", "History" or "Science Fiction".

Genre ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table.  

3.6.16 Insurance table

One field is linked to this lookup table: Book.Insurance.

Address (Memo)
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Contact Person (Text 50)

Coverage (Numeric)

The insurance coverage.

E-mail (Text 100)

Fax (Text 25)

Insurance Company (Text 50)

The name of the insurance company.

Insurance ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Phone (Text 25)

Policy (Text 50)

The name of the insurance policy.

Policy Number (Text 25)

The insurance policy number.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

Web Link (Text)

3.6.17 Keyword table

Two fields are linked to this lookup table: Book.Keywords and Contents.Keywords.
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Keyword (Text 50)

The keyword.

Keyword ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table.  

3.6.18 Language table

Four fields are linked to this lookup table: Book.Language, Book.Original Language,
Contents.Language and Contents.Original Language.

Language (Text 50)

The language.

Language ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table.  
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3.6.19 Location table

One field is linked to this lookup table: Book.Location.

Location (Text 50)

The location description.

Location ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table.  

3.6.20 Owner table

One field is linked to this lookup table: Book.Owner.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Owner (Text 50)

The name of the owner.

Owner ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Sort by (Text 52)



BookCAT Help118

© 2012 FNProgramvare

This text value is used when sorting on a field linked to this lookup table. 

3.6.21 Person table

3.6.21.1 Standard fields

The following fields are linked to this lookup table: Contents.Leading Role, Contents.
Supporting Role, and Contents.Crew.

Address (Memo)

Biography (Memo)

Birth Name (Text 100)

Birth Location (Text 150)

Born (Date)

Country (Text 50 - lookup )

Death Location (Text 150)

Died (Date)

E-mail (Text 100)

Fax (Text 25)

File Links (Text)

Image 1-9 (Binary)

This field contains the actual image if the image is stored in the database.

Image 1-9 - Compressed (Yes/No)

Specifies whether the image is compressed or not (only applies to BMP images).

Image 1-9 - External (Yes/No)

Specifies whether the image is stored externally (only the file path to the image file is
stored in the database), or not.

Image 1-9 - File name (Text 255)

If you have linked to an external image, this field contains the file name.

112
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Image 1-9 - Notes (Memo)

This memo field is for your own notes about the image.

Image 1-9 - Thumbnail (Binary)

This is a thumbnail of the image. The thumbnail is automatically created when you add
a new image.

Image 1-9 - Type (Numeric)

The type of image: 0 - bmp, 1 - gif, 2 - jpeg, 3 - png, or 99 - other.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Name (Text 100)

The name of the person. 

Person ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Pseudonym (Text 50 - lookup )

This field allows you to link the "real" name of an author to one or more pseudonyms.
You find more information here .

Phone (Text 25)

Relation (Text)

Use this field to link to other related persons (authors).You can also add your own
notes.

Sort by (Text 102)

This text value is used when sorting on a field linked to this lookup table. 

Web Link (Text)

118
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3.6.21.2 Custom fields

To rename a custom field, open the data entry window, right-click the data field and
choose Rename Field from the popup menu. You can also rename fields from the
'Database Setup' window (Tools=>Database Setup). 

The Person table contains the following custom fields:

Text 

Custom 01, Custom 02

Lookup 

Custom 03, Custmo 04

Memo

Custom 05

Date 

Custom 06

Numeric 

Custom 11

Checkbox 

Custom 07, Custom 08, Custom 09, Custom 10

3.6.22 Personal Rating table

One field is linked to this lookup table: Book.Personal Rating.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Personal Rating (Text 50)

The personal rating text.
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Personal Rating ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Rating Image (Binary)

Use this field to store a rating image with the rating. The rating image is shown in lists
where you select rating in the data entry window, in the browse list, in reports and in
the explorer. 

This image must be a GIF file and maximum size is 50x100 pixels.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

3.6.23 Printed by table

One field is linked to this lookup table: Book.Printed by.

Address (Memo)

E-mail (Text 100)

Fax (Text 25)

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Phone (Text 25)

Printed by (Text 50)

The name of the company that has printed the book.

Printed by ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Sort by (Text 52)
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This text value is used when sorting on a field linked to this lookup table. 

Web Link (Text 100)

3.6.24 Printing table

One field is linked to this lookup table: Book.Printing.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Printing (Text 50)

Printing ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

3.6.25 Publication Place

One field is linked to this lookup table: Book.Publication Place.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Publication Place (Text 50)

The place of publication.

Publication Place ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.
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Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

3.6.26 Publisher table

Three fields are linked to this lookup table: Book.Publisher, Book.Original Publisher and
Want list.Publisher.

Address (Memo)

E-mail (Text 100)

Fax (Text 25)

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Phone (Text 25)

Publisher (Text 50)

The name of the publisher.

Publisher ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

Web Link (Text 100)

3.6.27 Record Link Type table

You can assign a type to each link in the Book Links field.

Marked (Yes/No)

This field indicates whether the record is marked or not.



BookCAT Help124

© 2012 FNProgramvare

Notes (Memo)

This memo field is for your own notes.

Record Link Type (Text 50)

The name of the link type.

Record Link Type ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

3.6.28 Series table

Five fields are linked to this lookup table: Book.Series, Book.Original Series, Contents.
Series, Contents.OriginalSeries and Want List.Series.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Series (Text 50)

The name of the series.

Series ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

3.6.29 Status table

One field is linked to this lookup table: Book.Status.

Background Color (Numeric)

This color is used to color code books with this status in the Book View when "status
color coding" is enabled in options.
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Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 

Status (Text 50)

The status description, for example "Own" or "For Sale".

Status ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

3.6.30 Sub-Category table

One field is linked to this lookup table: Book.Sub-Category.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This memo field is for your own notes.

Sub-Category (Text 50)

The sub-category description.

Sub-Category ID (Numeric)

This is an unique ID number that is assigned to each record in the table. You cannot
edit this field.

Sort by (Text 52)

This text value is used when sorting on a field linked to this lookup table. 
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3.6.31 Web Link Type table

You can assign a type to each link in the Web Links field.

Marked (Yes/No)

This field indicates whether the record is marked or not.

Notes (Memo)

This field is for your own notes.

Web Link Type (Text 50)

The type description.

Web Link Type ID (Numeric)

This is an unique ID number that is assigned to each entry in the table.
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4 Other products

4.1 AssetCAT

Home page  Download

AssetCAT is a powerful inventory database program that will assist you in keeping track
of your household items, valuables and collectibles. AssetCAT allows you to catalog a
wide range of information, and create customized reports with details on each item
including photos for your own records, or to share with your insurance agent so that
you will be prepared if a disaster strikes. 

 

http://www.fnprg.com/assetcat/index.html
http://www.fnprg.com/assetcat/download.html


Index 129

© 2012 FNProgramvare

Index
- A -
About databases     10

About reports     72

Acquire from scanner     39

Acquired from table     105

Actor data - download     43

Add book     28

Add column     56

Add image     39

Add lookup data     32

Add reservation     49

Add segment     29

Add want list     38

Add-Ons     7

Advanced search     68

Aliases     35

Appraiser table     106

AssetCAT     128

Author pseudonyms     35

Auto-backup     12

Auto-organize image files     39

Award table     107

- B -
Backup database     12

Bands     79

Binding table     107

Book table: Custom fields     98

Book table: Standard fields     89

Book Type table     108

Book view     27, 51

BookCAT database     89

Books     28

Borrower     46

Borrower Category table     110

Borrower table: Custom fields     109

Browse list     56

- C -
Card list     56

Category table     110

Change column order     56

Check book in     47

Check in     48

Check out     48

Check out book     47

Clear reservation     49

Column order     56

Compact database     12

Condition table     111

Contact FNProgramvare     8

Contents data     29

Contents table: Custom fields     102

Contents table: Standard fields     99

Contents templates     31

Contents Type table     111

Contents view     27, 51

Corrupt database     13

Country table     112

Create database     10

Create filter     60

Create grouping     62

Create new report     75

Create reports     74

Create sort order     58

Customize database     17

Customize the explorer     63

- D -
Data entry layout     17

Data fields     89

Database password     11

Database Setup window     17

Delete book     28

Delete filter     60

Delete grouping     62

Delete list layout     56

Delete report object     81

Delete segment     29

Delete sort order     58

Design reports     74

Download actor data     43

Download from Internet     43

Dustjacket Dustjacket Condition table     112



BookCAT Help130

© 2012 FNProgramvare

- E -
Edit book     28

Edit column     56

Edit field names     17

Edit filter     60

Edit grouping     62

Edit image     39

Edit list layout     56

Edit lookup data     32

Edit report menu     86

Edit report object     81

Edit segment     29

Edit sort order     58

Edit want list     38

Edition table     113

E-mail     50

Excel export     14

Excel import     16

Explorer     63

Explorer pane     63

Explorer view     63

Export     13

Export to Excel     14

Export to HomeBase     14

Export to HTML     15

Export to iPod     15

Export to text file     16

Export to XML     16

Extend loan period     51

- F -
Field names     17

Field rename     17

File Link Type table     113

Filter     60, 76

Fix database     13

Form Designer     20

Form Designer - Add data field     21

Form Designer - Delete object     25

Form Designer - Modify properties     24

Form Designer - Move field to another tab     24

Form Designer - Move object     23

Form Designer - Resize object     23

Form Designer - Select object     23

Form Designer - Set tab order     25, 26

Form Designer - tab control     22

Form Designer - Update group titles     26

Form Designer - Update Use property     27

- G -
Genre table     114

Getting started     3

Global search     70

Grouping     62, 76

Grouping definition     62

Guest password     11

- H -
Help     8

HomeBase export     14

How to export     13

How to import     13

How to order     7

How to search     66

HTML export     15

- I -
Images     39

Import     13

Import from Excel     16

Import from text file     16

Insert report object     81

Insurance table     114

Internet     43

iPod     15

iPod export     15

- K -
Keyword table     115

- L -
Language table     116

Layout of fields     17

List layout     55, 56

Loan     46



Index 131

© 2012 FNProgramvare

Loan management     46, 47, 48, 49, 50, 51

Loan out     48

Loan table     103

Loan View     27

Locate missing image files     39

Location table     117

Lookup data     34

Lookup tables     32

Lookup view     27, 51

- M -
Manage lookup tables     32

Mark records     54

MDB files     10

Move report object     81

Movies - download data     43

- N -
New database     10

New filter     60

New grouping     62

New sort order     58

Nicknames     35

Notification     50

- O -
Open database     11

Open report     75

Order     7

Other products     128

Owner table     117

- P -
Password     11

Pen names     35

Person table: Custom fields     120

Person table: Standard fields     118

Personal Rating table     120

Print data     72

Print out data     72

Print preview     86

Print report     86

Print to file     86

Printed by table     121

Printing table     122

Pseudonyms     35

Publisher table     123

- Q -
Quick Search     67

- R -
Record Link Type table     123

Remove list layout     56

Rename fields     17

Rename tables     17

Repair database     13

Replace field value     66, 72

Report Archive Reader     7

Report bands     79

Report filter     76

Report grouping     76

Report menu     86

Report object     81

Report options     76

Report sort order     76

Reports     72

Reservation     49

Reserve album     49

Resize report object     81

Restore backup     12

Return     48

- S -
Save report     75

Scan image     39

Scanner     39

Search     67, 68, 69, 70, 71

Search and replace     66, 72

Search list     67

Searching     66

Sections     29

Select multiple records     55

Select records     55

Selection     55

Send e-mail notifications     50

Series table     124



BookCAT Help132

© 2012 FNProgramvare

Set field value     43

Show marked records     54

Show subset     54

Simple search     67

Sort order     58, 76

Special searches     71

Split lookup item     34

Standard list     56

Status table     124

Statusbar     54

Sub-Category table     125

Subset     54

Summary search     69

Support     8

System requirements     7

- T -
Tab control     22

Table rename     17

Tables     125

Technical information     7

Technical support     8

Templates     31

Text file export     16

Text file import     16

The report designer     74

Tracking book on loan     46

Transfer information between databases     12

TV-Series - download data     43

Types of information     27

- U -
Update field value     43

- W -
Want list     38

Want list table     103

Want List View     27

Web Link Type table     126

Welcome     3

Working with views     51

- X -
XML export     16


	Introduction
	Getting started
	System Requirements
	Add-Ons
	How to order BookCAT
	Support
	Contacting FNProgramvare

	Using BookCAT
	Working with databases
	About databases
	Create a new database
	Open a databases
	Password protect a database
	Compact a database
	Transfer data between databases
	Backup database and restore backup
	Repair corrupted database
	Importing and exporting data
	Overview
	Export to Excel
	Export to HomeBase
	Export to HTML
	Export to iPod notes
	Export to text file
	Export to XML
	Import from Excel
	Import from text file

	Customizing the database
	Overview
	The Database Setup window 
	The Form Designer window
	Overview
	Add a data field
	How to use the tab control
	Select a form object
	Move a form object
	Resize a form object
	Modify form or object properties
	Move a form object to another tab
	Delete a form object
	How to set the tab order
	The Auto Update Tab Order function
	The Auto Update Groups function
	The Auto Update Use Property function



	Data entry
	Types of information
	Edit books
	Edit contents
	Contents templates
	Edit lookup information
	Split a lookup item
	Author pseudonyms
	Edit the want list
	Edit images
	The Set Field Value function
	Download information from the Internet
	Loan management
	Overview
	Check books out one at a time
	Check books in one at a time
	Check books out using the 'Check Titles In/Out' window
	Check books in using the 'Check Titles In/Out' window
	Reserve a book
	Clear reservations
	Send e-mail notifications
	Extend loan period


	Viewing information
	Working with views
	Marking records and showing the marked records
	Select multiple records in browse list
	List layouts
	Sort orders
	Filters
	Grouping
	The explorer

	Searching and querying
	How to search
	Quick search
	Simple search
	Advanced search
	Summary search
	Global search
	The special searches
	Search and replace

	Working with reports
	About reports
	The report designer
	Report files
	Report options
	Report bands
	Report objects
	Print the report
	The report menu


	The BookCAT Database
	Overview
	Book table
	Standard fields
	Custom fields

	Contents table
	Standard fields
	Custom fields

	Loan table
	Want List table
	Lookup tables
	Acquired From table
	Appraiser table
	Award table
	Binding table
	Book Type table
	Borrower table
	Standard fields
	Custom fields

	Borrower Category table
	Category table
	Condition table
	Contents Type table
	Country table
	Dustjacket Condition table
	Edition table
	File Link Type table
	Genre table
	Insurance table
	Keyword table
	Language table
	Location table
	Owner table
	Person table
	Standard fields
	Custom fields

	Personal Rating table
	Printed by table
	Printing table
	Publication Place
	Publisher table
	Record Link Type table
	Series table
	Status table
	Sub-Category table
	Web Link Type table


	Other products
	AssetCAT


